Modified: phpdoc/ja/trunk/reference/mongo/sqltomongo.xml =================================================================== --- phpdoc/ja/trunk/reference/mongo/sqltomongo.xml 2011-12-04 05:51:01 UTC (rev 320343) +++ phpdoc/ja/trunk/reference/mongo/sqltomongo.xml 2011-12-04 07:31:15 UTC (rev 320344) @@ -1,6 +1,6 @@ - +
SQL から Mongo への対応表 @@ -61,14 +61,6 @@ - SELECT a,b FROM users WHERE age=33 - - - $db->users->find(array("age" => 33), array("a" => 1, "b" => 1)); - - - - SELECT a,b FROM users WHERE age=33 ORDER BY name Modified: phpdoc/ja/trunk/reference/network/functions/dns-get-record.xml =================================================================== --- phpdoc/ja/trunk/reference/network/functions/dns-get-record.xml 2011-12-04 05:51:01 UTC (rev 320343) +++ phpdoc/ja/trunk/reference/network/functions/dns-get-record.xml 2011-12-04 07:31:15 UTC (rev 320344) @@ -1,6 +1,6 @@ - + dns_get_record @@ -492,10 +492,10 @@ &reftitle.notes; - 特定のプラットフォーム (Windows や *BDS、あるいは Mac) - でこの関数が実装されていなかったバージョンとの互換性を保持するには、 + PHP 5.3.0 より前のバージョンでは、OS によってはこの関数が実装されていませんでした。 + そのような環境との互換生を保つには、 PEAR の - Net_DNS クラスを試してみてください。 + Net_DNS クラスを使いましょう。 Modified: phpdoc/ja/trunk/reference/network/functions/setcookie.xml =================================================================== --- phpdoc/ja/trunk/reference/network/functions/setcookie.xml 2011-12-04 05:51:01 UTC (rev 320343) +++ phpdoc/ja/trunk/reference/network/functions/setcookie.xml 2011-12-04 07:31:15 UTC (rev 320344) @@ -1,6 +1,6 @@ - + setcookie @@ -51,7 +51,7 @@ setcookie の各パラメータがどのように作用するのかを知るには - RFC 2109 を参照ください。 + RFC 6265 を参照ください。 name @@ -117,13 +117,17 @@ domain - クッキーが有効なドメイン。 - exapmle.com の全てのサブドメイン (example.com 自身も含む) でクッキーを有効とするには - '.example.com' をセットします。 - 最初の . がなくてもクッキーを受け付けるブラウザもありますが、 - RFC 2109 では必ずつけなければならないことになっています。 - 'www.example.com' あるいは '.www.example.com' - クッキーは www サブドメインにおいてのみ有効となります。 + クッキーが有効なドメイン。ドメインを + 'www.example.com' に設定すると、 + www サブドメインおよびその上位のサブドメインでクッキーが使えるようになります。 + より低レベルのドメイン、たとえば + 'example.com' でクッキーを有効にすると、その上位にある + 'www.example.com' などのサブドメインでもクッキーが有効になります。 + + 古いブラウザの中には、非推奨になった + RFC 2109 を実装しているものが未だに残っているかもしれません。 + そのようなブラウザでは、すべてのサブドメインにマッチさせるためには先頭に + . が必要となります。 @@ -180,7 +184,7 @@ setcookie("TestCookie", $value); setcookie("TestCookie", $value, time()+3600); /* 有効期限は一時間です */ -setcookie("TestCookie", $value, time()+3600, "/~rasmus/", ".example.com", 1); +setcookie("TestCookie", $value, time()+3600, "/~rasmus/", "example.com", 1); ?> ]]> @@ -224,7 +228,7 @@ ]]> @@ -372,9 +376,8 @@ header setrawcookie クッキー - Netscape による最初のクッキーの仕様 + RFC 6265 RFC 2109 - RFC 2965 Modified: phpdoc/ja/trunk/reference/pcre/functions/preg-replace.xml =================================================================== --- phpdoc/ja/trunk/reference/pcre/functions/preg-replace.xml 2011-12-04 05:51:01 UTC (rev 320343) +++ phpdoc/ja/trunk/reference/pcre/functions/preg-replace.xml 2011-12-04 07:31:15 UTC (rev 320344) @@ -1,7 +1,7 @@ - - + + preg_replace @@ -282,7 +282,8 @@ ]]> - 入力テキストのすべての HTML タグを大文字に変換します。 + 入力テキストのすべての HTML タグを大文字に変換し、 + シングルクォートやダブルクォート、バックスラッシュそして NULL 文字はすべてエスケープします。 Modified: phpdoc/ja/trunk/reference/simplexml/functions/simplexml-load-file.xml =================================================================== --- phpdoc/ja/trunk/reference/simplexml/functions/simplexml-load-file.xml 2011-12-04 05:51:01 UTC (rev 320343) +++ phpdoc/ja/trunk/reference/simplexml/functions/simplexml-load-file.xml 2011-12-04 07:31:15 UTC (rev 320344) @@ -1,7 +1,7 @@ - - + + simplexml_load_file @@ -12,7 +12,7 @@ &reftitle.description; - objectsimplexml_load_file + SimpleXMLElementsimplexml_load_file stringfilename stringclass_name"SimpleXMLElement" intoptions0 @@ -92,7 +92,7 @@ SimpleXMLElement クラスのオブジェクトを返します。 XML ドキュメント内のデータをプロパティに含みます。 - エラー時には &false; を返します。 + &return.falseforfailure;。 Modified: phpdoc/ja/trunk/reference/simplexml/functions/simplexml-load-string.xml =================================================================== --- phpdoc/ja/trunk/reference/simplexml/functions/simplexml-load-string.xml 2011-12-04 05:51:01 UTC (rev 320343) +++ phpdoc/ja/trunk/reference/simplexml/functions/simplexml-load-string.xml 2011-12-04 07:31:15 UTC (rev 320344) @@ -1,7 +1,7 @@ - - + + simplexml_load_string @@ -12,7 +12,7 @@ &reftitle.description; - objectsimplexml_load_string + SimpleXMLElementsimplexml_load_string stringdata stringclass_name"SimpleXMLElement" intoptions0 @@ -82,7 +82,7 @@ SimpleXMLElement クラスのオブジェクトを返します。 XML ドキュメント内のデータをプロパティに含みます。 - エラー時には &false; を返します。 + &return.falseforfailure;。 Modified: phpdoc/ja/trunk/reference/sqlite/setup.xml =================================================================== --- phpdoc/ja/trunk/reference/sqlite/setup.xml 2011-12-04 05:51:01 UTC (rev 320343) +++ phpdoc/ja/trunk/reference/sqlite/setup.xml 2011-12-04 07:31:15 UTC (rev 320344) @@ -1,6 +1,6 @@ - + @@ -10,8 +10,8 @@
&reftitle.required; - SQLite 拡張モジュールは PHP 5 以降デフォルトで有効となります。 - それより前のバージョンでは SQLite ライブラリが必要でした。 + SQLite 拡張モジュールは PHP 5.0 以降デフォルトで有効となりました。 + PHP 5.4 以降では、SQLite 拡張モジュールは PECL 経由でのみ利用可能となります。
@@ -20,20 +20,9 @@
&reftitle.install; - PHP 5 以降、この拡張モジュールはデフォルトで有効となりました。 - 無効にしない限り、そのままで使用可能です。 + PHP 5.0 以降で、この拡張モジュールは PHP に同梱されるようになりました。 + PHP 5.4 以降では、SQLite 拡張モジュールは PECL 経由でのみ利用可能となります。 - - - PECL 版の拡張モジュールは使ってはいけません。 - これは保守されていないからです。 - たとえ共有モジュールとしてコンパイルされていたとしても、 - PHP のソースに付属する SQLite 拡張モジュールを使いましょう。 - ソースは php-src-dir/ext/sqlite - にあり、phpize - 方式でビルドすることができます。 - - Windows ユーザがこれらの関数を使用するには、php_sqlite.dll を &php.ini; で有効にしなければなりません。