[ANNOUNCEMENT] zip-1.5.0 (alpha) Released.

From: Date: Fri, 14 Jul 2006 10:24:46 +0000
Subject: [ANNOUNCEMENT] zip-1.5.0 (alpha) Released.
Groups: php.pecl.dev 
Request: Send a blank email to pecl-dev+get-3974@lists.php.net to get a copy of this message
The new PECL package zip-1.5.0 (alpha) has been released at http://pecl.php.net/. Release notes ------------- - bring consistency to the method names: - rename zip::delete() to deleteIndex() - add zip::deleteName() - rename zip::statPath to zip::statName() - rename zip::rename to zip::renameIndex() - add zip::renameName(); - add zip::locateName(), returns the index of an entry, allows case insensitive or directory free lookup (ZIP::FL_NOCASE, ZIP::FL_NODIR) - add zip::unchangeName(), ::unchangeIndex(), unchangeAll() and unchangeArchive() revert changes to an entry, to all entries or the archive - add zip::getNameIndex(), get the name of the entry at the given position - Bug #7658, Modify zip archives causes corruption if the data descriptor is used (bit 3 of the general flags) - fix a bug when in the delete and rename methods when the index is lower than 1 - zip::addFile() must return true on success - zip::open() returns now the error code on error and true on success Package Info ------------- Zip is an extension to create, modify and read zip files. Related Links ------------- Package home: http://pecl.php.net/package/zip Changelog: http://pecl.php.net/package-changelog.php?package=zip Download: http://pecl.php.net/get/zip-1.5.0.tgz Authors ------------- Pierre-Alain Joye (lead)

« previous php.pecl.dev (#3974) next »