Re: 3.0.5 beta

From: Date: Sun, 04 Oct 1998 18:33:50 +0000
Subject: Re: 3.0.5 beta
References: 1  Groups: php.beta 
Request: Send a blank email to php-beta+get-24@lists.php.net to get a copy of this message
At 12:28 04/10/98 -0400, Rasmus Lerdorf wrote: >> >There is a name clash between Apache and Postgres' Libpq (C frontend) >> >which results in a warning. palloc is defined in libpq-fe.h and >> >ap_compat.h (this isn't a result of a failure in PHP, of course). >> >> It should be ok. > >I think we should fix this. Apache went to the trouble of renaming all >internal functions to ap_*. We are remapping them back to the non ap_* >names with ap_compat.h in order to be compatible with Apache 1.2.x. We >can make a special case out of palloc and do a MODULE_MAGIC_NUMBER check >and call ap_palloc() if the version of Apache is recent enough. That will >get rid of that warning for all Apache 1.3.x systems at least. Do we actually call ap_palloc() or palloc() though? I don't think we're even using these functions. You could run a check that if the magic number suggests apache 1.3.x, you #undef palloc() after including the Apache headers... Zeev -- Zeev Suraski <zeev@php.net> For a PGP public key, finger bourbon@netvision.net.il

« previous php.beta (#24) next »