#36048 [Com]: ISAPI filter crash
ID: 36048
Comment by: scott at naimanclarke dot com dot au
Reported By: piadoso at pobox dot sk
Status: No Feedback
Bug Type: IIS related
Operating System: Windows 2000 Server
PHP Version: 4.4.2
New Comment:
This problem was traced to conflicting dll versions installed on the
server. Namely the PHP related dll's in C:\Windows\System32 were not
from the same release as those in C:\PHP.
Previous Comments:
------------------------------------------------------------------------
[2006-08-03 14:28:03] scott at naimanclarke dot com dot au
I was having the problem with 4.4.2 and found this bug. Just downloaded
and installed 4.4.3 and I am having the same problem. If I use php.exe
instead I get a headers misbehaving error instead of a crash. This
error only occurs with certain files (I think it is when file(), curl()
and fopen() commands are run). It could also be related to directory
permissions, although I have tried setting all of them to rx IUSR_* but
this has no effect.
------------------------------------------------------------------------
[2006-07-05 14:29:00] mark at xrar dot com dot au
I can confirm I was having a similar problem (same error message) with
a different PHP application on a IIS 6 box. Applying the latest CVS has
resolved the problem
------------------------------------------------------------------------
[2006-01-28 01:00:05] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2006-01-20 15:46:20] tony2001@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2006-01-20 15:38:18] bw_fotoart at yahoo dot de
Hi everyone!
After a security Update from PHP 4.4.1 to 4.4.2 on a IIS Server version
6.0 on a Windows 2003 Server
everythink in Joomla works fine, only the Joomla Newsfeeds.(Joomla!
1.0.4 Stable [ Sundial ] 21-Nov-2005 10:00 UTC)
After Clicking on a Mainmenü Link
(index.php?option=com_newsfeeds&task=view&feedid=1&Itemid=17) that
opens a newsfeed nothing happends. (no Data in the Document)
I found in the Windows 2003 Server Application Logfiles follow error.
Faulting application w3wp.exe, version 6.0.3790.1830, faulting module
php4isapi.dll, version 0.0.0.0, fault address 0x00002443.
This is not a Joomla Problem.
I Downgrade PHP back to 4.4.1 nowe everythink works fine.
Siri
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/36048
--
Edit this bug report at http://bugs.php.net/?id=36048&edit=1
Thread (9 messages)