#37322 [Com]: unable to link php to already installed mysql
| From: | guglielmo dot celata at gmail dot com | Date: | Fri, 22 Sep 2006 17:58:03 +0000 |
| Subject: | #37322 [Com]: unable to link php to already installed mysql | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-102539@lists.php.net to get a copy of this message | ||
ID: 37322
Comment by: guglielmo dot celata at gmail dot com
Reported By: raosid at rediffmail dot com
Status: No Feedback
Bug Type: *Configuration Issues
Operating System: fedora core 4
PHP Version: 4.4.2
New Comment:
Hi,
I am having the same issue, using php4.4.4 with mysql 5.0.22 on a FC5.
I have installed the mysql and mysql-devel packages, using yum.
Then, trying to compile, using:
./configure
--with-apxs2=/usr/local/apache2/bin/apxs
--with-mysql=/usr
--disable-cgi
--with-zlib --with-curl --with-gettext
--with-iconv --enable-mbstring --enable-shmop
--enable-sysvmsg --enable-sysvsem --enable-sysvshm
--with-pear --with-gd --with-jpeg-dir --with-png-dir
I receive the same error.
I think this is a bug and it should be fixed.
Previous Comments:
------------------------------------------------------------------------
[2006-08-02 15:51:03] sorin at intersol dot ro
OOps, My mistake. I think that the problem is that the compiled mysql
in FC4 and FC5 may not include old functions?!
Any suggestion not including the recompilation of mysql.
------------------------------------------------------------------------
[2006-08-02 15:47:27] sorin at intersol dot ro
It seamns that you must define USE_OLD_FUNCTIONS before including
mysql.h (At least in mysql 5 the missing functions are including only
if USE_OLD_FUNCTIONS is defined).
------------------------------------------------------------------------
[2006-08-02 15:37:22] sorin at intersol dot ro
I confirm this bug in Fedora Core 5.
------------------------------------------------------------------------
[2006-05-14 01:00:00] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2006-05-06 09:30:41] tony2001@php.net
It looks like you have a headers mess in your system.
The configure option should be --with-mysql='INSTALL PREFIX of mysql',
not SOURCE.
Please try using the right option and post the results here.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/37322
--
Edit this bug report at http://bugs.php.net/?id=37322&edit=1