#38960 [Fbk->Opn]: OCI8 failure...
| From: | sn4265 at att dot com | Date: | Wed, 27 Sep 2006 22:16:33 +0000 |
| Subject: | #38960 [Fbk->Opn]: OCI8 failure... | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-102837@lists.php.net to get a copy of this message | ||
ID: 38960
User updated by: sn4265 at att dot com
Reported By: sn4265 at att dot com
-Status: Feedback
+Status: Open
Bug Type: Compile Failure
Operating System: HPUX 11.11
PHP Version: 5.1.6
New Comment:
One step forward two steps back. The make command succeeded fine, but
now the Apache webserver won't load.
root@hostname:/> /opt/apache/bin/apachectl -k start
/usr/lib/dld.sl: Can't shl_load() a library containing Thread Local
Storage: /usr/lib/libcl.2
/usr/lib/dld.sl: Exec format error
Syntax error on line 232 of /opt/apache/conf/httpd.conf:
Cannot load /opt/apache/modules/libphp5.so into server: Exec format
error
Previous Comments:
------------------------------------------------------------------------
[2006-09-27 20:49:04] tony2001@php.net
Please try the following:
1) open instantclient_10_2/sdk/include/oratypes.h
2) find this line:
#if (__STDC__ != 1) || defined(__LP64__)
and change it to
#if defined (__STDC_EXT__) || defined(__LP64__)
3) run make again.
------------------------------------------------------------------------
[2006-09-27 12:24:55] sn4265 at att dot com
OK... The database servers that I am connecting to are remote, and are
all Oracle 9i or greater. I spent much of last night downloading and
attempting to build PHP 5.1.6 with the Oracle Instant Client as
suggested. Unfortunately, I am still running into problems. Here is
what I am facing at this point.
The configure script completes fine as follows:
./configure --with-mysql
--with-oci8=shared,instantclient,/usr/local/oracle/instantclient_10_2
--with-apxs2=/opt/apache/bin/apxs
The make fails at the following point:
/bin/sh /www/tmp/php-5.1.6/libtool --silent --preserve-dup-deps
--mode=compile gcc -Iext/oci8/ -I/www/tmp/php-5.1.6/ext/oci8/
-DPHP_ATOM_INC -I/www/tmp/php-5.1.6/include -I/www/tmp/php-5.1.6/main
-I/www/tmp/php-5.1.6 -I/usr/local/include/libxml2
-I/www/tmp/php-5.1.6/ext/date/lib -I/usr/include/mysql
-I/usr/local/oracle/instantclient_10_2/sdk/include
-I/www/tmp/php-5.1.6/TSRM -I/www/tmp/php-5.1.6/Zend
-D_XOPEN_SOURCE_EXTENDED -I/usr/local/include -g -O2 -c
/www/tmp/php-5.1.6/ext/oci8/oci8_lob.c -o ext/oci8/oci8_lob.lo
/www/tmp/php-5.1.6/ext/oci8/oci8_lob.c: In function
`php_oci_lob_read':
/www/tmp/php-5.1.6/ext/oci8/oci8_lob.c:226: error: `oraub8' undeclared
(first use in this function)
/www/tmp/php-5.1.6/ext/oci8/oci8_lob.c:226: error: (Each undeclared
identifier is reported only once
/www/tmp/php-5.1.6/ext/oci8/oci8_lob.c:226: error: for each function it
appears in.)
/www/tmp/php-5.1.6/ext/oci8/oci8_lob.c:226: error: parse error before
')' token
/www/tmp/php-5.1.6/ext/oci8/oci8_lob.c:226: error: parse error before
')' token
/www/tmp/php-5.1.6/ext/oci8/oci8_lob.c:226: error: parse error before
"offset"
*** Error exit code 1
Stop.
Once again I'm stuck. Thanks again for any assistance.
------------------------------------------------------------------------
[2006-09-26 22:02:39] tony2001@php.net
>Is this a major change to PHP5?
>Does it now only work with a more limited set of Oracle clients?
Yes, there was a major change in OCI8, which greatly improved its
functionality using new features available since Oracle 9.
It still does work with Oracle 8 servers, but I don't think it makes
sense to keep supporting (seriously) outdated Oracle 8.x clients.
The easiest (and the recommended) way to setup a server with OCI8
support is to install Oracle Instant Client, doesn't matter which
platform/OS you're using.
I guess in your case the solution would be to stick with
PHP4/PHP5.0.x.
Other options are a bit more complicated:
1) upgrade the client to 9i (afaik instant client doesn't support
Oracle < 8i)
2) upgrade both Oracle server and client to version >= 9.
------------------------------------------------------------------------
[2006-09-26 12:34:52] sn4265 at att dot com
No clue. I have never used that before. This system has had Oracle
8.0.6.3 on it for years, and has always been what we have built against
in the past without any problems. Is this a major change to PHP5? Does
it now only work with a more limited set of Oracle clients?
------------------------------------------------------------------------
[2006-09-26 12:28:49] tony2001@php.net
Does it work for you with Oracle Instant Client -
http://www.oracle.com/technology/tech/oci/instantclient/index.html
?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/38960
--
Edit this bug report at http://bugs.php.net/?id=38960&edit=1