#38987 [Bgs]: isapi_fcgi.dll has problems with search engine friendly paths
| From: | randy at rcs-comp dot com | Date: | Fri, 29 Sep 2006 02:07:13 +0000 |
| Subject: | #38987 [Bgs]: isapi_fcgi.dll has problems with search engine friendly paths | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-102872@lists.php.net to get a copy of this message | ||
ID: 38987
User updated by: randy at rcs-comp dot com
Reported By: randy at rcs-comp dot com
Status: Bogus
Bug Type: IIS related
Operating System: Win XP
PHP Version: 5.2.0RC4
New Comment:
Can you please tell me how this is related to PECL? I have looked
through the PECL packages and do not find this project listed. In
addition, the package itself is outside the PECL folder in CVS.
Previous Comments:
------------------------------------------------------------------------
[2006-09-28 22:55:30] tony2001@php.net
Please report issues related to PECL projects to PECL bug tracker.
------------------------------------------------------------------------
[2006-09-28 22:27:30] randy at rcs-comp dot com
Actually, the error comes from the isapi_fcgi.dll module I believe:
http://viewcvs.php.net/viewvc.cgi/fastcgi-isapi/isapi_fcgi/isapi_fcgi.cpp?revision=1.3&view=markup
Also, there is another bug dealing with this module that makes me think
that PHP developers are working on this module? Here is the reference:
http://bugs.php.net/bug.php?id=37448
(The bug is not necessarily related to mine though, just both being
caused by isapi_fcgi.dll)
------------------------------------------------------------------------
[2006-09-28 22:19:49] tony2001@php.net
>I see in CVS that there have been some changes in this area
What do you mean?
>Is there a configuration or something that I can change to make this
work?
The error message comes from IIS, not PHP, so I have serious doubts we
can help you.
------------------------------------------------------------------------
[2006-09-28 21:33:57] randy at rcs-comp dot com
Description:
------------
I am using the code (and dll) from here:
http://msmvps.com/blogs/guilherme/archive/2006/02/02/82336.aspx
on a Windows XP machine with IIS 5.1.
It runs well, except for one problem. I use the PATH_INFO information
to run scripts that are search engine friendly. So, I can have a path
like this:
http://www.example.com/index.php/view/News-Main
Which works fine. I can also pass other variables like this:
http://www.example.com/index.php/view/News-Main/article/hi_there
Which also works fine. However, I have a content module that uses urls
like this:
http://www.example.com/index.php/view/Content-Main/page/index.html
Which gives me the following error:
Error initializing bind path for
index.php/view/Content-Main/page/index.html
I see in CVS that there have been some changes in this area (I guess
this error would have crashed the server before?). Is there a
configuration or something that I can change to make this work? I
don't understand why it is happening?
There is no problem with this when I use php directly and bypass
isapi_fcgi.dll.
Thanks.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=38987&edit=1