#39002 [NEW]: apache 2.2.3 don't start : R_PPC_REL24 relocation error

From: Date: Sat, 30 Sep 2006 09:32:33 +0000
Subject: #39002 [NEW]: apache 2.2.3 don't start : R_PPC_REL24 relocation error
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-102915@lists.php.net to get a copy of this message
From: benoitc at archlinuxppc dot org Operating system: Arch Linux PPC PHP version: 5.1.6 PHP Bug Type: Apache2 related Bug description: apache 2.2.3 don't start : R_PPC_REL24 relocation error Description: ------------ Apache 2.2.3 don't start with last version of php 5.1.6. I have this error : Reproduce code: --------------- Php configure line : ./configure --with-apxs2 --prefix=/usr --sysconfdir=/etc \ --with-layout=PHP \ --with-ttf --enable-mailparse --with-config-file-scan-dir=/etc \ --enable-bcmath=shared --enable-calendar=shared --enable-ftp=shared \ --enable-gd-native-ttf --enable-magic-quotes --enable-posix=shared \ --enable-session --enable-shared --enable-shmop=shared --enable-pdo=shared \ --enable-sqlite-utf8 --enable-sockets=shared --enable-xml\ --enable-sysvsem=shared --enable-sysvshm=shared --enable-sysvmsg=shared \ --enable-track-vars --enable-trans-sid --enable-safe-mode \ --with-imap --with-imap-ssl --with-ncurses --with-readline \ --with-bz2=shared --with-curl --with-mime-magic \ --with-freetype-dir=/usr --with-gd=shared --enable-exif --with-jpeg-dir=/usr \ --enable-dba --without-db2 --without-db3 --with-inifile --with-flatfile \ --with-gdbm --with-ldap=shared --with-openssl --with-gettext \ --with-unixODBC=shared,/usr --with-pdo-odbc=shared,unixODBC,/usr \ --with-mysqli=shared,/usr/bin/mysql_config --with-mysql-sock=/tmp/mysql.sock \ --with-pdo-mysql=shared,/usr --with-mysql=shared,/usr \ --with-pgsql=shared --with-pgsql-sock=/tmp/pgsql.sock --with-pdo-pgsql=shared,/usr \ --with-sqlite=shared --with-pdo-sqlite=shared,/usr \ --with-pear=/usr/share/pear --with-dom --with-dom-xslt --with-xsl \ --with-png-dir=/usr --with-regex=php --with-zlib --enable-soap=shared \ --enable-mbstring=all --enable-mbregex --with-snmp=shared,/usr Actual result: -------------- httpd: Syntax error on line 114 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/libphp5.so into server: /etc/httpd/modules/libphp5.so: R_PPC_REL24 relocation at 0x0d81ae40 for symbol `free' out of range -- Edit bug report at http://bugs.php.net/?id=39002&edit=1 -- Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=39002&r=trysnapshot44 Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=39002&r=trysnapshot52 Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=39002&r=trysnapshot60 Fixed in CVS: http://bugs.php.net/fix.php?id=39002&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=39002&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=39002&r=needtrace Need Reproduce Script: http://bugs.php.net/fix.php?id=39002&r=needscript Try newer version: http://bugs.php.net/fix.php?id=39002&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=39002&r=support Expected behavior: http://bugs.php.net/fix.php?id=39002&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=39002&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=39002&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=39002&r=globals PHP 3 support discontinued: http://bugs.php.net/fix.php?id=39002&r=php3 Daylight Savings: http://bugs.php.net/fix.php?id=39002&r=dst IIS Stability: http://bugs.php.net/fix.php?id=39002&r=isapi Install GNU Sed: http://bugs.php.net/fix.php?id=39002&r=gnused Floating point limitations: http://bugs.php.net/fix.php?id=39002&r=float No Zend Extensions: http://bugs.php.net/fix.php?id=39002&r=nozend MySQL Configuration Error: http://bugs.php.net/fix.php?id=39002&r=mysqlcfg

« previous php.bugs (#102915) next »