Bug #14594 Updated: Failed to compile/run when using Apache 2.x, unresolved symbols

From: Date: Thu, 13 Jun 2002 13:04:29 +0000
Subject: Bug #14594 Updated: Failed to compile/run when using Apache 2.x, unresolved symbols
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-10329@lists.php.net to get a copy of this message
ID: 14594 Updated by: jjas@engr.uky.edu Reported By: juraj@bednar.sk Status: Closed Bug Type: Apache2 related Operating System: FreeBSD 4.4-STABLE PHP Version: 4.1.0 New Comment: Installing gnu-pth is the solution, not just a work around. Take a look at the port's Makefile: /usr/ports/www/mod_php4/Maiefile. You'll see that it also installs gnu-pth. The problem isn't just a PHP problem. I've encountered this compiling numerous packages on FreeBSD 4.x because FreeBSD <= 4 does not have a working pthread library. You have to use compiler tricks to compile threaded software and some packages still won't work unless a real thread library is installed. FreeBSD 5.0 supposedly corrects this, but I haven't tried it. Previous Comments: ------------------------------------------------------------------------ [2002-06-05 18:00:21] juraj@bednar.sk As you can see in the history, this is fairly common, at least a warning during ./configure would be nice (i.e. -- you can't compile this without --with-tsrm-pth and quit). Because people will always try to compile it without. Or enabling --with-tsrm-pth on freebsd by default and raising error, when the library is not found. Hm? Because now you closed the bug, provided a workaround (not a solution) and people will have to google out the workaround, since there's no documentation for it. ------------------------------------------------------------------------ [2002-06-05 14:34:16] spammerprotect@aol.com This seems to be an FreeBSD Error only. To solve first install pth-1.4 package from the ports The you have to recompile php with the option: --with-tsrm-pth, to make him use the gnu pth instead of the posix ones (that dont seem to work with FBSD) then rebuild and reinstall the php-mod and it will just work fine Cheers Fire -------------------------------------------------------- On [18 Dec 2001 6:40pm] juraj@bednar.sk wrote : I compiled standard Apache-2.0.28beta, then downloaded php-4.1.0, compiled it just with --with-mysql and --with-apxs2=/usr/local/apache2/bin/apxs After sucessful make install, I tried to run /usr/local/apache2/bin/httpd, which resulted in this error: Syntax error on line 3 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/local/apache2/modules/libphp4.so: Undefined symbol "pthread_getspecific" ------------------------------------------------------------------------ [2002-05-21 16:08:10] stimpy@broekiemedia.nl I'm using FreeBSD 4.5, Apache-2.0.35 for freebsd 4.5, mysql-3.23.49-unknown-freebsdelf4.4-i386 I compiled with --with-mysql=/usr/local/mysql --with-apxs2=/usr/local/apache2/bin/apxs httpd.conf contains: LoadModule php4_module modules/libphp4.so AddType application/x-httpd-php .php And also I get this error: Failed to start apache : Syntax error on line 217 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/local/apache2/modules/libphp4.so: Undefined symbol "pthread_getspecific" /usr/local/apache2/bin/apachectl start: httpd could not be started ------------------------------------------------------------------------ [2002-05-01 20:59:20] erkan.boga@netiq.com I am using FreeBSD 4.5, Apache 2.0.35, GNU Pth 1.4.1 and PHP 4.2 I still get the error Cannot load /prog/httpd/modules/libphp4.so into server: /prog/httpd/modules/libphp4.so: Undefined symbol "pthread_getspecific" ./apachectl start: httpd could not be started even if i have installed php 4.2 with the --with-tsrm-pth option I have spend now 5 hours to find a solution but i couldn't find any workaround... any ideas ? regards, erkan ------------------------------------------------------------------------ [2002-04-19 11:36:18] aaron@php.net This bug has already been fixed in the latest released version of PHP, which you can download at http://www.php.net/downloads.php The apache2filter is known to work with Apache 2.0.35 and either CVS HEAD or the 4.2.0 branch (or the latest release candidate). Please report back if you have any problems related to FreeBSD 4.x and these versions. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/14594 -- Edit this bug report at http://bugs.php.net/?id=14594&edit=1

« previous php.bugs (#10329) next »