#39316 [Fbk->Csd]: extension_dir (in php.ini) has no effect in Windows
ID: 39316
User updated by: aren at cambre dot biz
Reported By: aren at cambre dot biz
-Status: Feedback
+Status: Closed
Bug Type: Unknown/Other Function
Operating System: Windows Server 2003
PHP Version: 5.1.6
New Comment:
OK, the resolution is complicated.
http://us2.php.net/manual/en/install.windows.iis.php
has a
documentation error: "Modify the Windows PATH environment variable to
include the PHP directory. This way the PHP DLL files, PHP executables,
and php.ini can all remain in the PHP directory without cluttering up
the Windows system directory. For more details, see the FAQ on Setting
the PATH."
I did that, and contrary to what that says, PHP did not read php.ini
out of c:\php. It was reading it out of c:\windows. I did have a
php.ini in c:\windows, but it may have been from a prior installation.
After creating a PHPRC environment variable (per the badly buried
document at
http://us2.php.net/manual/en/configuration.php#configuration.file),
php
started reading the correct c:\php\php.ini file, and things tentatively
seem to be working correctly. (At least I am getting a different error
from my application now!)
I have a separate bug report on the documentation error, so I will
close this out.
Previous Comments:
------------------------------------------------------------------------
[2006-11-08 15:29:58] tony2001@php.net
Please make sure you've put libmysql.dll into PATH, rebooted your
webserver and if it still doesn't work, please show your phpinfo().
------------------------------------------------------------------------
[2006-11-08 15:17:01] aren at cambre dot biz
Oops, correcting the summary.
------------------------------------------------------------------------
[2006-11-08 15:16:17] aren at cambre dot biz
Wrong-o.
I loaded up filemon. You are correct that php is reading a php.ini in
c:\windows. However, that file contains this line:
extension_dir = c:\PHP\ext
Next?
------------------------------------------------------------------------
[2006-11-08 14:27:01] tony2001@php.net
You are changing wrong php.ini.
Check phpinfo() to see which php.ini is used.
------------------------------------------------------------------------
[2006-11-02 21:54:16] noah dot rusnock at echo-digitaldesign dot com
I just setup a Windows 2000 SP4 virtual machine using Microsoft
VirturalPC 2007 beta. I used the exact same setup as I did for my
Windows XP (non-virtual machine) Apache server with PHP and I am still
unable to load any extensions.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/39316
--
Edit this bug report at http://bugs.php.net/?id=39316&edit=1
Thread (10 messages)