#39523 [NEW]: ibase_pconnect does not reconnect when a connection is dropped
| From: | jacques@php.net | Date: | Wed, 15 Nov 2006 10:18:26 +0000 |
| Subject: | #39523 [NEW]: ibase_pconnect does not reconnect when a connection is dropped | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-105011@lists.php.net to get a copy of this message | ||
From: jacques@php.net
Operating system: Redhat Linux RHEL4
PHP version: 5.2.0
PHP Bug Type: InterBase related
Bug description: ibase_pconnect does not reconnect when a connection is dropped
Description:
------------
Using the interbase/firebird database, when using persistent connections,
it does not reconnect to the database when the link is dropped
(leased-line goes down / manually killing the firebird server process on
the database server). It just returns the database link to a dead
connection.
Using a DB wrapper / ibase_pconnect natively, they both have the same
problem.
Reproduce code:
---------------
Mail me for the source code.
Expected result:
----------------
A new link should be established prior to returning the persistent
connection.
Actual result:
--------------
$result->getMessage() returns "DB Error: unknown error"
--
Edit bug report at http://bugs.php.net/?id=39523&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=39523&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=39523&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=39523&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=39523&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=39523&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=39523&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=39523&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=39523&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=39523&r=support
Expected behavior: http://bugs.php.net/fix.php?id=39523&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=39523&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=39523&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=39523&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=39523&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=39523&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=39523&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=39523&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=39523&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=39523&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=39523&r=mysqlcfg