Bug #14547 Updated: Informix as shared module libtool rpath problem

From: Date: Sun, 16 Jun 2002 03:56:08 +0000
Subject: Bug #14547 Updated: Informix as shared module libtool rpath problem
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-10549@lists.php.net to get a copy of this message
ID: 14547 Updated by: zhamm@secmgmt.com Reported By: zhamm@secmgmt.com -Status: Feedback +Status: Open Bug Type: Informix related Operating System: RH Linux 7.1 PHP Version: 4.1.0 New Comment: Please try compiling it as shared. I'll try the same from the snapshot. Previous Comments: ------------------------------------------------------------------------ [2002-06-15 20:37:09] sniper@php.net This snapshot: http://snaps.php.net/php4-latest.tar.gz Works for me with Informix CSDK 2.70.UC3. Although I did only compile it as static module, not shared. But it _should_ work fine as shared too. --Jani ------------------------------------------------------------------------ [2002-02-12 08:47:04] jfuertes@maz.es The same happens with the latest snapshot from today. ------------------------------------------------------------------------ [2002-02-12 03:55:09] jfuertes@maz.es Same problem over Suse 7.3 Pro. PHP's Informix support is very very low and bad. ¿Informix programers have best things to do than help php to suppor they? ------------------------------------------------------------------------ [2001-12-18 18:24:53] zhamm@secmgmt.com Upgraded to RH 7.2 to use the newer version of libtool. No joy. Same exact problem. Zack ------------------------------------------------------------------------ [2001-12-16 09:46:41] zhamm@secmgmt.com When configuring/compiling PHP 4.1.0 on RH 7.1, I can successfully compile PHP with informix built in, but not as a shared module. (INFORMIXDIR, INFORMIXSERVER, and PATH already set) Thus, "# ./configure --with-apxs=/usr/sbin/apxs --with-informix --enable-shared --with-mysql=/usr --with-gd --with-zlib --with-gettext --with-png" works just fine. However, "# ./configure --with-apxs=/usr/sbin/apxs --enable-shared --with-informix=shared --with-mysql=/usr --with-gd --with-zlib --with-gettext --with-png" fails with: Making install in informix make[2]: Entering directory `/php/php-4.1.0/ext/informix' make[3]: Entering directory `/php/php-4.1.0/ext/informix' /bin/sh /php/php-4.1.0/libtool --silent --mode=link gcc -I. -I/php/php-4.1.0/ext/informix -I/php/php-4.1.0/main -I/php/php-4.1.0 -I/usr/include/apache -I/php/php-4.1.0/Zend -I/opt/informix/incl/esql -I/usr/include/mysql -I/php/php-4.1.0/ext/xml/expat -DLINUX=22 -DMOD_SSL=208101 -DEAPI -DEAPI_MM -DUSE_EXPAT -I/php/php-4.1.0/TSRM -g -O2 -prefer-pic -o informix.la -avoid-version -module -rpath /p hp/php-4.1.0/modules ifx.lo -Rext/informix -Lext/informix -R/opt/informix/lib/esql -L/opt/informix/lib/esql -R/opt/informix/lib -L/opt/informix/lib -lifsql -l ifasf -lifgen -lifos -lifgls -ldl -lcrypt -lphpifx -lifglx libtool: link: only absolute run-paths are allowed make[3]: *** [informix.la] Error 1 make[3]: Leaving directory `/php/php-4.1.0/ext/informix' make[2]: *** [install-recursive] Error 1 make[2]: Leaving directory `/php/php-4.1.0/ext/informix' make[1]: *** [install-recursive] Error 1 make[1]: Leaving directory `/php/php-4.1.0/ext' make: *** [install-recursive] Error 1 Since I know nothing about libtool, I'm not even sure where to start to make a path absolute. I *guess* this is a bug, but perhaps maybe pilot error? Should I be using some other configuration directive? This is the format I used with 4.0.2 and it worked fine. Zack ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=14547&edit=1

« previous php.bugs (#10549) next »