#39729 [Opn->Fbk]: relocation error loading libphp5.so

From: Date: Mon, 04 Dec 2006 15:20:08 +0000
Subject: #39729 [Opn->Fbk]: relocation error loading libphp5.so
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-105881@lists.php.net to get a copy of this message
 ID:               39729
 Updated by:       tony2001@php.net
 Reported By:      wzaccone at telcordia dot com
-Status:           Open
+Status:           Feedback
 Bug Type:         Dynamic loading
 Operating System: Solaris 9
 PHP Version:      5.2.0
 New Comment:

Please also update to the latest version of Apache 2.0.x.


Previous Comments:
------------------------------------------------------------------------

[2006-12-04 15:12:41] wzaccone at telcordia dot com

Description:
------------
using PHP 5.2.0 on Solaris 9. Apache 2.0.54
upgraded to latest rev of Solaris 9 using gnu ld

have been unable start apache, php5 module is getting following error:

Syntax error on line 234 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp5.so into server: ld.so.1:
httpd: fatal: relocation error: file
/usr/local/apache/modules/libphp5.so: symbol apr_pool_cleanup_null:
referenced symbol not found

configure command is shown below:

configure --prefix=/usr/local/apache/lib
--exec-prefix=/usr/local/apache --with-apxs2=/usr/local/apache/bin/apxs
--enable-sockets --enable-ftp --enable-track-vars --enable-soap




------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=39729&edit=1


Thread (6 messages)

« previous php.bugs (#105881) next »