#39697 [Opn->Bgs]: apxs:Error: Command failed with rc=65536

From: Date: Sun, 10 Dec 2006 11:41:30 +0000
Subject: #39697 [Opn->Bgs]: apxs:Error: Command failed with rc=65536
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-106160@lists.php.net to get a copy of this message
ID: 39697 Updated by: tony2001@php.net Reported By: michael dot v dot kells at uscg dot mil -Status: Open +Status: Bogus Bug Type: Compile Failure Operating System: Centos PHP Version: 5.2.0 New Comment: Please reopen the report when/if you have more information on this issue. At the moment it looks like the problem is in your system/libraries, rather than PHP. Previous Comments: ------------------------------------------------------------------------ [2006-12-04 20:48:51] ccohen at ntelos dot net Hate to admit this (blush), but I solved this problem by double checking the dependencies on all of the different modules I was asking PHP to install and making sure I had up to date versions of all the shared libraries by installing them all again in this order: libiconv ./configure --enable-extra-encodings --prefix=/usr/lib libxml2 ./configure --with-iconv=/usr/lib/ --prefix=/usr/lib/ libxslt ./configure --prefix=/usr/lib/ --with-libxml-prefix=/usr/lib/ --with-libxml-include-prefix=/usr/lib/include/ --with-libxml-libs-prefix=/usr/lib/lib/ zlib ./configure --shared --prefix=/usr/lib/ libmcrypt* ./configure --disable-posix-threads --prefix=/usr/lib libltdl ./configure --prefix=/usr/lib --enable-ltdl-install mhash ./configure --prefix=/usr/lib libidn ./configure --with-iconv-prefix=/usr/lib/ --prefix=/usr/lib/ make install then worked just like it was supposed to (surprise). Hope this little confession helps somebody. ------------------------------------------------------------------------ [2006-12-04 16:32:55] michael dot v dot kells at uscg dot mil Their are no warnings or errors when I run configure or make. [root@localhost php-5.2.0]# ls -al libs/ total 8 drwxr-xr-x 2 root root 4096 Dec 1 09:58 . drwxr-xr-x 17 1002 1002 4096 Dec 1 09:58 .. "/www/bin/apxs" I have compiled and installed Apache prior to trying to install PHP. So apxs is a tool for building and installing extension modules for Apache. "/www/bin/httpd -l" [root@DSES-Cacti-test1 ~]# /www/bin/httpd -l Compiled in modules: core.c mod_authn_file.c mod_authn_default.c mod_authz_host.c mod_authz_groupfile.c mod_authz_user.c mod_authz_default.c mod_auth_basic.c mod_include.c mod_filter.c mod_log_config.c mod_env.c mod_setenvif.c prefork.c http_core.c mod_mime.c mod_status.c mod_autoindex.c mod_asis.c mod_cgi.c mod_negotiation.c mod_dir.c mod_actions.c mod_userdir.c mod_alias.c mod_so.c ------------------------------------------------------------------------ [2006-12-03 18:48:22] ccohen at ntelos dot net php 5.1.4 was previously installed as part of apache, not DSO/style, so it wasn't exactly a "roll back" :D ------------------------------------------------------------------------ [2006-12-03 16:54:41] tony2001@php.net >just tried to roll back to 5.1.4 and am now getting same problem again Did it work before? If yes, what has changed since then? ------------------------------------------------------------------------ [2006-12-03 16:33:05] ccohen at ntelos dot net I also have the newest version of libtool installed: ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06) ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/39697 -- Edit this bug report at http://bugs.php.net/?id=39697&edit=1

« previous php.bugs (#106160) next »