#40068 [Opn->Fbk]: Warning: Unknown: failed to open stream: No such file or directory in Unknown..
| From: | iliaa@php.net | Date: | Wed, 10 Jan 2007 03:53:26 +0000 |
| Subject: | #40068 [Opn->Fbk]: Warning: Unknown: failed to open stream: No such file or directory in Unknown.. | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-107400@lists.php.net to get a copy of this message | ||
ID: 40068
Updated by: iliaa@php.net
Reported By: triphius at tripslair dot com
-Status: Open
+Status: Feedback
Bug Type: Scripting Engine problem
Operating System: FreeBSD 6.1
PHP Version: 5.2.0
New Comment:
Please update the report once you have the results from the
php-cvs run.
Previous Comments:
------------------------------------------------------------------------
[2007-01-09 04:16:27] triphius at tripslair dot com
I installed PHP using FreeBSD's ports system. The configure command
generated by the ports installer is as follows:
Configure Command => './configure' '--enable-versioning'
'--enable-memory-limit' '--with-layout=GNU'
'--with-config-file-scan-dir=/usr/local/etc/php' '--disable-all'
'--enable-libxml' '--with-libxml-dir=/usr/local' '--enable-reflection'
'--enable-spl' '--program-prefix=' '--enable-fastcgi'
'--with-apxs=/usr/local/sbin/apxs' '--with-regex=php'
'--with-zend-vm=CALL' '--enable-zend-multibyte' '--prefix=/usr/local'
I also installed the php5-extensions port with the following modules
selected:
extension=ctype.so
extension=curl.so
extension=dom.so
extension=exif.so
extension=gd.so
extension=gettext.so
extension=iconv.so
extension=mbstring.so
extension=mcrypt.so
extension=mhash.so
extension=mysql.so
extension=mysqli.so
extension=openssl.so
extension=pcre.so
extension=pdf.so
extension=zlib.so
extension=pdo.so
extension=posix.so
extension=session.so
extension=simplexml.so
extension=snmp.so
extension=sockets.so
extension=tokenizer.so
extension=xml.so
extension=xmlreader.so
extension=xmlwriter.so
I am going to uninstall all of that and attempt to install from the CVS
source as per your recommendation.
------------------------------------------------------------------------
[2007-01-08 20:53:53] iliaa@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5.2-win32-latest.zip
Do you have any Zend or compiler cache extensions enabled?
------------------------------------------------------------------------
[2007-01-08 20:51:05] triphius at tripslair dot com
Description:
------------
When loading any page on the web server, the user randomly gets
presented with the following error:
Warning: Unknown: failed to open stream: No such file or directory in
Unknown on line 0
Fatal error: Unknown: Failed opening required
'/path/to/script/here.php' (include_path='.:') in Unknown on line 0
This happens with every PHP script, and it appears to be totally
random. The error message itself has no useful information to help
determine the cause of the error.
The server in question is running FreeBSD 6.1 and Apache 1.3.37 and PHP
5.2.0.
Reproduce code:
---------------
As this problem occurs randomly on any script...it does not make sense
to be a script issue.
Expected result:
----------------
The page to load normally, 100% of the time.
Actual result:
--------------
Sometimes the page loads normally, sometimes you get the error message
as stated above.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=40068&edit=1