#40448 [NEW]: SOAP Server Extension - Fails with SOAP1.1 compliant envelope
| From: | dreddy at duke-energy dot com | Date: | Mon, 12 Feb 2007 14:43:13 +0000 |
| Subject: | #40448 [NEW]: SOAP Server Extension - Fails with SOAP1.1 compliant envelope | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-108738@lists.php.net to get a copy of this message | ||
From: dreddy at duke-energy dot com
Operating system: AIX 5.3
PHP version: 5.2.1
PHP Bug Type: SOAP related
Bug description: SOAP Server Extension - Fails with SOAP1.1 compliant envelope
Description:
------------
We are using PHP version 5.1.6 (not in the drop down for bugs)
Testing Flash8 Webservice Component connecting to a PHP5 SOAP Extension
soap server, and the Apache listener will generate an internal server
error (500).
Problem appears to be libsoap not handling what appears to be a valid
SOAP1.1 envelope, even if the the soap server is defined to be SOAP1.1.
The workaround for us, is to use NuSoap, which is a SOAP 1.1
implementation.
Reproduce code:
---------------
The problem is the additional element on the BODY tab, legit in SOAP1.1
but not in SOAP1.2
<SOAP-ENV:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body
xmlns:ns1="urn
:myquote"><ns1:getQuote><symbol>ibm</symbol></ns1:getQuote></SOAP-ENV:Body></SOAP-ENV:Envelope>
See http://www.w3.org/TR/2003/REC-soap12-part0-20030624/#L4697
...and look for a section titled, "6. Changes Between SOAP 1.1 and SOAP
1.2"
The first item under additional or changed syntax:
SOAP 1.2 does not permit any element after the body. The SOAP 1.1 schema
definition allowed for such a possibility, but the textual description is
silent about it.
--
Edit bug report at http://bugs.php.net/?id=40448&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=40448&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=40448&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=40448&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=40448&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=40448&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=40448&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=40448&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=40448&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=40448&r=support
Expected behavior: http://bugs.php.net/fix.php?id=40448&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=40448&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=40448&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=40448&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=40448&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=40448&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=40448&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=40448&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=40448&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=40448&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=40448&r=mysqlcfg