ID: 38982
Comment by: mi7892 at hotmail dot com
Reported By: admin at denic-294 dot de
Status: No Feedback
Bug Type: OpenSSL related
Operating System: Debian different releases
PHP Version: 4.4.4
New Comment:
I got the same problem too, i compile php-4.4.4 with following
command:
./configure --prefix=/usr/local/php4
--with-config-file-path=/usr/local/php4 --with-mysql=/usr/local/mysql
--with-openssl=/usr/local/ssl --with-apxs2=/usr/local/apache2/bin/apxs
--disable-all
and run the following php in cli.
<?php
$a = file_get_contents('https://www.interwetten.com');
?>
I got the following result:
[root@www2 bin]# ./php ~/a.php
Warning: file_get_contents(): php_stream_sock_ssl_activate_with_method:
failed to create an SSL context in /root/a.php on line 3
Warning: file_get_contents(https://www.interwetten.com): failed to open
stream: Unable to activate SSL mode in /root/a.php on line 3
here is the result from php -m
[root@myserver bin]# ./php -m
[PHP Modules]
mysql
openssl
standard
[Zend Modules]
Previous Comments:
------------------------------------------------------------------------
[2006-10-06 01:00:01] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2006-09-28 15:28:02] tony2001@php.net
Please try to configure it with just ./configure --disable-all
--with-openssl.
------------------------------------------------------------------------
[2006-09-28 15:10:04] iliaa@php.net
Does php -m show the ssl extension as being loaded?
------------------------------------------------------------------------
[2006-09-28 14:59:59] admin at denic-294 dot de
The php-source:
---------------
1: #!/root/php-4.4.4/sapi/cli/php
2: <?php
[...]
67: $fp=fsockopen("ssl://".$host,$port,$errno,$errstr);
[...]
The result:
-----------
Warning: fsockopen(): no SSL support in this build in
/home/.../script.php on line 67
Warning: fsockopen(): unable to connect to xxxx.xxxx:12345 in
/home/.../script.php on line 67
The configure-command:
----------------------
./configure --disable-cgi --with-mysql --with-openssl
(It worked with the same command after the patch)
I tried compiling with debian woody and debian sarge on different
servers which did not affect the result in any way.
Is there any more information that would help you ?
------------------------------------------------------------------------
[2006-09-28 14:31:42] tony2001@php.net
ssl://, ftps:// and https:// work here in CLI with just --with-openssl
and without any patches.
I asked you for additional information, I didn't ask you to repeat the
same as in your first message.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/38982--
Edit this bug report at http://bugs.php.net/?id=38982&edit=1