#40580 [Opn->Bgs]: Does PHP 5.2.1 work with openssl 0.9.8
| From: | tony2001@php.net | Date: | Wed, 21 Feb 2007 15:09:25 +0000 |
| Subject: | #40580 [Opn->Bgs]: Does PHP 5.2.1 work with openssl 0.9.8 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-109267@lists.php.net to get a copy of this message | ||
ID: 40580
Updated by: tony2001@php.net
Reported By: wzaccone at telcordia dot com
-Status: Open
+Status: Bogus
Bug Type: Dynamic loading
Operating System: Solaris 10
PHP Version: 5.2.1
New Comment:
>PHP 5.2.1 requires that I use openssl 0.9.7
No, you've linked it against 0.9.7.
Previous Comments:
------------------------------------------------------------------------
[2007-02-21 15:02:46] wzaccone at telcordia dot com
Description:
------------
Built PHP 5.2.1 for Solaris 10 using openssl 0.9.8 for Apache 2.0.59,
but PHP will not run. it is looking for openssl 0.9.7 which I no longer
have my system. I have openssl 0.9.8 installed.
Not sure why PHP it is looking for openssl 0.9.7. Before I search for a
hidden openssl 0.9.7 include file,
can someone tell me whether PHP 5.2.1 requires that I use openssl 0.9.7
?
Reproduce code:
---------------
configure command for PHP 5.2.1 was..
./configure --prefix=/usr/local/apache/lib
--exec-prefix=/usr/local/apache --with-apxs2=/usr/local/apache/bin/apxs
--with-openssl=/usr/local/apache/ssl --with-curl=/usr/local
--enable-sockets --enable-ftp --enable-track-vars --enable-soap
Expected result:
----------------
# apachectl configtest
Syntax error on line 232 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp5.so into server: ld.so.1:
httpd: fa
tal: libssl.so.0.9.7: open failed: No such file or directory
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=40580&edit=1