Bug #15888 Updated: Crashes when using --with-mm
| From: | sniper@php.net | Date: | Tue, 18 Jun 2002 00:26:09 +0000 |
| Subject: | Bug #15888 Updated: Crashes when using --with-mm | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-10982@lists.php.net to get a copy of this message | ||
ID: 15888
Updated by: sniper@php.net
Reported By: thomas.grotevent@gmx.de
-Status: Open
+Status: Closed
Bug Type: Reproducible crash
Operating System: Linux (SuSE 7.3)
PHP Version: 4.1.2
New Comment:
AFAIK, this was fixed in 4.2.1 already. If not, please try
this snapshot and reopen if the bug exists in it:
http://snaps.php.net/php4-latest.tar.gz
Previous Comments:
------------------------------------------------------------------------
[2002-03-09 15:29:45] thomas.grotevent@gmx.de
I've tested a Snapshot of march 06.. The error is gone with
the snapshot version and comes up again when switching back to the
4.1.2 version.
i tried to backtrace this error with gdb. But i'm not a real
programmer and got lot's of difficulties. The apache webserver does not
start php at all if i try to start via gdb.
I'll try to figure out if i can get this work.
Thomas
------------------------------------------------------------------------
[2002-03-05 17:06:49] derick@php.net
Can you try a snapshot from snaps.php.net to see if it's fixed AND
provide a backtrace of this crash?
Derick
------------------------------------------------------------------------
[2002-03-05 17:00:48] thomas.grotevent@gmx.de
I've configured 4.1.1 and 4.1.2 with the same options:
--with-apxs=/usr/local/httpd/bin/apxs \
--prefix=/usr/local/php \
--sysconfdir=/etc/php \
--enable-force-cgi-redirect \
--with-config-file-path=/etc/php \
--enable-safe-mode \
--enable-track-vars \
--with-db3 \
--with-gd \
--with-mysql=/usr/local/mysql \
--with-gettext \
--with-mm \
--enable-ftp \
--with-imap-ssl \
--with-zlib \
--with-png \
--disable-debug \
--with-xml \
--with-mcrypt \
--with-imap
Setting session.save_handler = mm in the php.ini results in an error
message of the apache webserver:"child pid xxx exit signal Segmentation
Fault (11)" when using version 4.1.2 and calling e.g. the test.php of
the horde framework or SquirrelMail. The version 4.1.1 works fine.
No compilation errors or similar showed up.
The mm version is 1.1.3.
Regards
Thomas
(Please apologize my english... ;-)
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=15888&edit=1