Bug #16221 Updated: Crash after 50-164 odbc queries on db2 dbase server

From: Date: Tue, 18 Jun 2002 00:44:14 +0000
Subject: Bug #16221 Updated: Crash after 50-164 odbc queries on db2 dbase server
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-10988@lists.php.net to get a copy of this message
ID: 16221 Updated by: sniper@php.net Reported By: j.marijne@webxpose.nl -Status: Open +Status: Feedback -Bug Type: Reproducible crash +Bug Type: ODBC related Operating System: Windows 2000 UK Advanced Server PHP Version: 4.1.2 New Comment: Does this happen with this snapshot: http://snaps.php.net/win32/php4-win32-latest.zip Previous Comments: ------------------------------------------------------------------------ [2002-03-22 10:31:50] j.marijne@webxpose.nl After doing between 50-182 query's to IBM DB2 7 on Windows 2000 (localhost) with this script: <? $connection = odbc_connect( "test","db2admin", "admin" ) or die("Unable to connect to SQL server"); } $result=odbc_exec($connection,"set current sqlid = 'DB2ADMIN'"); $counter=0; while ($counter <5000) { $query="select * from tms_user"; $result=odbc_exec($connection,$query); $temp=odbc_fetch_row ($result); echo "counter= $counter <br>"; odbc_free_result($result); odbc_close_all(); $counter++; } ?> I get the following error: Warning: SQL error: [IBM][CLI Driver][DB2/NT] SQL0954C Not enough storage is available in the application heap to process the statement. SQLSTATE=57011 , SQL state 57011 in SQLExecDirect in f:\inetpub\wwwroot\mr-sales-mysql\test.php on line 13 Warning: Supplied argument is not a valid ODBC result resource in f:\inetpub\wwwroot\mr-sales-mysql\test.php on line 14 counter= 164 If I use an odbc connection to a mysql database server, everything works fine. Kind regards, Joop Marijne WebXpose The Netherlands ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=16221&edit=1

« previous php.bugs (#10988) next »