#40701 [Opn]: Memory allocation error

From: Date: Tue, 13 Mar 2007 04:55:56 +0000
Subject: #40701 [Opn]: Memory allocation error
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-110324@lists.php.net to get a copy of this message
ID: 40701 User updated by: michaeldaly at magma dot ca Reported By: michaeldaly at magma dot ca Status: Open Bug Type: Unknown/Other Function Operating System: Win XP Pro PHP Version: 5.2.2 New Comment: With memory_limit = -1 there is no change. Previous Comments: ------------------------------------------------------------------------ [2007-03-12 03:40:34] edink@php.net Just out of the curiousity: what happens when you disable memory limit altogether? memory_limit=-1 ------------------------------------------------------------------------ [2007-03-07 16:04:57] michaeldaly at magma dot ca > It _does_ report 8Mb - "PHP Fatal error: Out of memory (allocated > 8388608) (tried to allocate 393216 bytes)". It also reports from 786KB to 9.2MB, so it appears that if the problem is a limit set externally, that limit is floating dynamically. > Yes, please search for "memory_limit" in your scripts,.htacess > and httpd.conf. I searched for "memory" in the entire Apache directory tree and found nothing that resembles a limit. I looked through httpd.conf and httpd_vhosts.conf visually and can find nothing else that looks like a memory restriction. The only limit I can find is in PHP.ini. ------------------------------------------------------------------------ [2007-03-07 09:13:06] tony2001@php.net >PHP does _not_ report 8MB - it reports 512MB as per the php.ini setting. It _does_ report 8Mb - "PHP Fatal error: Out of memory (allocated 8388608) (tried to allocate 393216 bytes)". >This is reported in phpinfo.php. memory_limit can be changed per-virtualhost, per-directory and per-script. Therefore phpinfo() might show you 512Mb, but the real script might use different value. >Is there a way for me to capture some kind of debug information >that can help you? Yes, please search for "memory_limit" in your scripts,.htacess and httpd.conf. ------------------------------------------------------------------------ [2007-03-06 20:54:33] michaeldaly at magma dot ca Is there a way for me to capture some kind of debug information that can help you? I downloaded the debug files along with the latest snap and they were just PDB files and I don't know what to do with them. ------------------------------------------------------------------------ [2007-03-06 18:10:37] tony2001@php.net Cannot reproduce anything like that. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/40701 -- Edit this bug report at http://bugs.php.net/?id=40701&edit=1

« previous php.bugs (#110324) next »