Bug #15324 Updated: CGI version (php.exe) times out
| From: | derick@php.net | Date: | Tue, 18 Jun 2002 09:39:54 +0000 |
| Subject: | Bug #15324 Updated: CGI version (php.exe) times out | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-11089@lists.php.net to get a copy of this message | ||
ID: 15324
Updated by: derick@php.net
Reported By: isitlive@altavista.com
-Status: Open
+Status: Feedback
Bug Type: IIS related
Operating System: Win2K
PHP Version: 4.1.1
New Comment:
Is this fixed with PHP 4.2.1?
Derick
Previous Comments:
------------------------------------------------------------------------
[2002-03-15 20:08:54] max@artco.com
I had the same problem running php 4.04 as CGI on WinNT 4.0. I found
that if the registry key
(HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\tcpip\parameters\SynAttackProtect
= 2) exists and is set I get the bug that is discussed in this report.
By deleteing the SynAttackProtect key, I am no longer get the "The
script started fromt he URL...." error and my server no longer
crashes.
Before removeing the SynAttackProtect key from the registry I would get
the above error and then my smpt server and ftp services would stop
responding, and my web service would stop after 5-10 minutes after the
smtp and ftp untill eventually the server crashed and needed to be
restarted.
for more info on the SynAttackProtect registry value you can visit
microsoft KB#
http://support.microsoft.com/search/preview.aspx?scid=kb;en-us;Q315669
------------------------------------------------------------------------
[2002-02-25 21:28:11] WPinegar@healthtech.net
I've seen the same problem. You're right, adding the ISAPI filter does
solve the problem.
------------------------------------------------------------------------
[2002-02-01 18:39:56] isitlive@altavista.com
note: I think we may have isolated the ISAPI problem...4.1.1 seems to
crash in IIS (Win2K) after some period of dormancy only if it is *not*
installed as an ISAPI filter as well as an ISAPI application, contrary
to the advice given in the installation notes.
------------------------------------------------------------------------
[2002-02-01 10:27:53] isitlive@altavista.com
I attempted to use php.exe (with IIS) rather than the ISAPI module of
PHP 4.1.1, as the ISAPI consistently crashes after laying dormant for a
period of time in IIS. This bug is alluded to in the latest release
notes, and I don't believe it has been solved.
Having been warned that the ISAPI is not stable, I decided to run the
CGI. I followed the installation instructions, and granted execute
access for c:\php to IISUSR_computername
Problem is, the exe hangs and eventually produces a timeout error in
IIS. I am using file includes on each of my pages.
Error:
The script started from the URL '/index.php' with parameters '' has not
responded within the configured timeout period. The HTTP server is
terminating the script.
For additional information specific to this message please visit the
Microsoft Online Support site located at:
http://www.microsoft.com/contentredirect.asp.
Confused...
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=15324&edit=1