#40978 [Asn]: PHP 5.2.1 Installer failure
| From: | jim_mcnally at yahoo dot com | Date: | Wed, 04 Apr 2007 16:07:59 +0000 |
| Subject: | #40978 [Asn]: PHP 5.2.1 Installer failure | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-111101@lists.php.net to get a copy of this message | ||
ID: 40978
User updated by: jim_mcnally at yahoo dot com
Reported By: jim_mcnally at yahoo dot com
Status: Assigned
Bug Type: Unknown/Other Function
Operating System: Windows VISTA
PHP Version: 5.2.1
Assigned To: jmertic
New Comment:
Additionally, I tried the PHP manual installation process, and got the
dread ERROR 404.3.
I also tried another installer package: "PHP Installer 1.6 for PHP
5.2.1 Setup" with the same results.
ERROR 404.3 is given in full below. Any help would be most appreciated.
Jim
------------------------------------------------------
HTTP Error 404.3 - Not Found
Description: The page you are requesting cannot be served because of
the Multipurpose Internet Mail Extensions (MIME) map policy that is
configured on the Web server. The page you requested has a file name
extension that is not recognized, and is not allowed.
Error Code: 0x80070032
Notification: ExecuteRequestHandler
Module: StaticFileModule
Requested URL: http://jtmal2:80/hello.php
Physical Path: C:\inetpub\wwwroot\hello.php
Logon User: Anonymous
Logon Method: Anonymous
Handler: StaticFile
Most likely causes:
It is possible that a handler mapping is missing. By default, the
static file handler processes all content.
The feature you are trying to use may not be installed.
The appropriate MIME map is not enabled for the Web site or
application. (Warning: Do not create a MIME map for content that users
should not download, such as .ASPX pages or .config files.)
What you can try:
In system.webServer/handlers:
Ensure that the expected handler for the current page is mapped.
Pay careful attention to preconditions (e.g. runtimeVersion,
pipelineMode, bitness) and compare them to the settings for your
application pool.
Pay careful attention to typographical errors in the expected handler
line.
Please verify that the feature you are trying to use is installed.
Verify that the MIME map is enabled or add the MIME map for the Web
site using the command-line tool appcmd.exe.
Open a command prompt and change directory to
%windir%\system32\inetsrv.
To set a MIME type, use the following syntax: appcmd set config
/section:staticContent /+[fileExtension='string',mimeType='string']
The variable fileExtension string is the file name extension and the
variable mimeType string is the file type description.
For example, to add a MIME map for a file which has the extension
".xyz", type the following at the command prompt, and then press Enter:
appcmd set config /section:staticContent
/+[fileExtension='.xyz',mimeType='text/plain']
Warning: Ensure that this MIME mapping is needed for your Web server
before adding it to the list. Configuration files such as .CONFIG or
dynamic scripting pages such as .ASP or .ASPX, should not be downloaded
directly and should always be processed through a handler. Other files
such as database files or those used to store configuration, like .XML
or .MDF, are sometimes used to store configuration information.
Determine if clients can download these file types before enabling them.
Create a tracing rule to track failed requests for this HTTP status
code. For more information about creating a tracing rule for failed
requests, click here.
-----------------------------------------
Previous Comments:
------------------------------------------------------------------------
[2007-04-02 15:44:18] jim_mcnally at yahoo dot com
Description:
------------
PHP 5.2.1 installer package terminated before installing. message from
Vista: "There was a problem with this Windows Installer package. A
program that was run as part of this setup did not finish as expected.
Contact your package vendor."
IIS v. 7.0 was installed and it works.
PHP 5.2.1 installer was run selecting "IIS CGI'. No other options were
selected.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=40978&edit=1