#41219 [Opn->Bgs]: PHP Warning: PHP Startup: Unable to load dynamic library

From: Date: Sat, 28 Apr 2007 16:24:20 +0000
Subject: #41219 [Opn->Bgs]: PHP Warning: PHP Startup: Unable to load dynamic library
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-112027@lists.php.net to get a copy of this message
ID: 41219 Updated by: tony2001@php.net Reported By: purley at eastlink dot ca -Status: Open +Status: Bogus Bug Type: *Extensibility Functions Operating System: Win XP PHP Version: 5.2.1 New Comment: >After finding that many people had this problem, I was unable to find an explanation. Open the corresponding page in the docs and read "Requirements" section. Previous Comments: ------------------------------------------------------------------------ [2007-04-28 15:08:44] purley at eastlink dot ca Description: ------------ At first (many) attempt to start Apache after adding php, I got: PHP Warning: PHP Startup: Unable to load dynamic library for many extensions. After finding that many people had this problem, I was unable to find an explanation. After commenting out all extensions and trying each one at a time, I found that the dll's which had prerequisites would give this error even though the named dll was present. The distribution does not include all of the dll's necessary to load the extensions. The required extensions may be found here: http://pecl4win.php.net/list_dlls.php In addition to the distribution missing required files, the error message is extremely misleading as it names the incorrect missing file. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=41219&edit=1

« previous php.bugs (#112027) next »