#41369 [Opn]: undefined reference to `ssl_onceonlyinit'
ID: 41369
User updated by: Ipseno at yahoo dot com
Reported By: Ipseno at yahoo dot com
Status: Open
Bug Type: IMAP related
Operating System: FreeBSD 6
PHP Version: 5.2.2
New Comment:
This time I've reached for a last resort option and that is completely
DELETING php folder
Then:
tar -xvf php-5.2.2.tar (NOT re-downloaded again)
./configure - copy-paste it like before (imap without SSL)
make
make test
make install
Then I deleted "new" php.ini and restored one "old" one that 5.2.1 used
and voila!
It started to work
PS: This are my failed tests:
FAILED TEST SUMMARY
---------------------------------------------------------------------
Error message handling (with ZendOptimizer)
[tests/run-test/test008.phpt]
Convert warnings to exceptions [tests/lang/038.phpt]
Bug #32828 (Throwing exception in output_callback function with
ob_start and ob_end_clean leads to segfault) [tests/lang/bug32828.phpt]
Bug #36268 (Object destructors called even after fatal errors)
[Zend/tests/bug36268.phpt]
Bug #41117 (Altering $this via argument) [Zend/tests/bug41117_1.phpt]
easter_date() [ext/calendar/tests/easter_date.phpt]
unixtojd() [ext/calendar/tests/unixtojd.phpt]
Bug #31422 No Error-Logging on SoapServer-Side
[ext/soap/tests/bugs/bug31422.phpt]
Bug #41004 minOccurs="0" and null class member variable
[ext/soap/tests/bugs/bug41004.phpt]
Bug #41097 (ext/soap returning associative array as indexed without
using WSDL) [ext/soap/tests/bugs/bug41097.phpt]
SOAP Server 14: fault [ext/soap/tests/server014.phpt]
IPv6 Loopback test [ext/sockets/tests/ipv6loop.phpt]
Bug #35821 (array_map() segfaults when exception is throwed from the
callback) [ext/standard/tests/array/bug35821.phpt]
Bug #38450 (constructor is not called for classes used in userspace
stream wrappers) [ext/standard/tests/file/bug38450_2.phpt]
proc_open [ext/standard/tests/general_functions/proc_open02.phpt]
Bug #20134 (UDP reads from invalid ports)
[ext/standard/tests/network/bug20134.phpt]
htmlentities() test 2 (setlocale / fr_FR.ISO-8859-15)
[ext/standard/tests/strings/htmlentities02.phpt] (warn: possibly
braindead libc)
htmlentities() test 4 (setlocale / ja_JP.EUC-JP)
[ext/standard/tests/strings/htmlentities04.phpt]
htmlentities() test 15 (setlocale / KOI8-R)
[ext/standard/tests/strings/htmlentities15.phpt]
Bug #32001 (xml_parse*() goes into infinite loop when autodetection in
effect), using UTF-* [ext/xml/tests/bug32001.phpt]
=====================================================================
Previous Comments:
------------------------------------------------------------------------
[2007-05-12 16:52:18] Ipseno at yahoo dot com
No I don't guarante that c-client is built with SSL support.
I haven't compiled it myself, bit added it like a freebsd port"
pkg_add -r port_name.
I also disagree, because, It wouldn't work then with current 5.2.1
They share same config so error would appear in 5.2.1 as well as in
5.2.2
PS: In 5.2.1 I used IMAP without --with-imap-ssl=/usr/local/openssl
option so it worked without IMAP ssl. Exactly same I wana apply to
5.2.2.
That is without --with-imap-ssl=/usr/local/openssl in .config
------------------------------------------------------------------------
[2007-05-12 01:59:01] scottmac@php.net
Are you sure that your c-client is built with SSL support?
The error you are seeing would happen if this wasn't the case.
------------------------------------------------------------------------
[2007-05-11 22:56:14] Ipseno at yahoo dot com
Yes, that is 100% - I've double checked that.
Completely same ./config options
They can't be mistyped because I've copy pasted it from text file.
All works with 5.2.1, but all same enviroment fail with 5.2.2
------------------------------------------------------------------------
[2007-05-11 19:12:09] sniper@php.net
Did you compile with exactly same configure line? (nothing has changed
in PHP that could have broken this..)
------------------------------------------------------------------------
[2007-05-11 17:54:10] Ipseno at yahoo dot com
Description:
------------
I am using FreeBSD 6 and it has imap 2004g
./config options are same like ones for previous version(5.2.1) I have
installed
With 5.2.1 - works!
With 5.2.2 - doesn't!
Simple as that.
Error that I get after "make":
ext/imap/.libs/php_imap.o(.text+0x4c1): In function `zm_startup_imap':
/usr/local/lib/php-5.2.2/ext/imap/php_imap.c:481: undefined reference
to `ssl_onceonlyinit'
*** Error code 1
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=41369&edit=1
Thread (7 messages)