#41367 [Asn]: PHP5.2.2 windows installer application mapping mistake and internal error 500
| From: | jmertic@php.net | Date: | Wed, 16 May 2007 17:36:45 +0000 |
| Subject: | #41367 [Asn]: PHP5.2.2 windows installer application mapping mistake and internal error 500 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-112710@lists.php.net to get a copy of this message | ||
ID: 41367
Updated by: jmertic@php.net
Reported By: zhaoliang_97 at hotmail dot com
Status: Assigned
Bug Type: Unknown/Other Function
Operating System: Windows Server 2003
PHP Version: 5.2.2
Assigned To: jmertic
New Comment:
yaz doesn't appear to be building from snaps at the moment. I'm going
to get the installer for 5.2.2 respun.
Previous Comments:
------------------------------------------------------------------------
[2007-05-16 16:22:28] zhaoliang_97 at hotmail dot com
Test Platform :
Windows2000 + sp4 + iis5 + isapi
Windows2003 + sp2 + iis6 + isapi
No, It still dosen't work(could not install). During the installation
process (status:copy new files) the installer pops an error message
window. The error info is below:
The installer has encountered an unexpected error install this
package. This may indicate a problem with this package. The error code
is 2356.
But Why the latest installer is so small?
------------------------------------------------------------------------
[2007-05-16 15:55:48] jmertic@php.net
Try latest installer from snaps to see if it does the correct
behavior.
http://snaps.php.net/win32/php5.2-win32-installer-latest.msi
------------------------------------------------------------------------
[2007-05-14 14:38:29] zhaoliang_97 at hotmail dot com
I have spent a whole afternoon to test PHP5.2.2 installer under
windows
2000 server sp4(iis5 + isapi).
Now my total test result of PHP5.2.2 installer is:
windows server 2003 + iis6 + isapi : Need to change the wrong
application mapping to work(don't forget to restart iis to load
php.ini).
windows 2000 server sp4 + iis5 + isapi : although the application
mapping still wrong but change it is no use to make php work.
------------------------------------------------------------------------
[2007-05-12 18:38:22] rickywalt1 at msn dot com
see bug 41377 also.
I found this bug also. Changed the path but it didn't help me.
------------------------------------------------------------------------
[2007-05-11 15:59:28] zhaoliang_97 at hotmail dot com
Description:
------------
I installed PHP5.2.2 ISAPI on windows server 2003(IIS 6) using the
PHP5.2.2 windows installer(offical). PHP installed under c:\php5. I
didn't load any extensions and did no changes in php.ini. Then i place a
test.php file which has only phpinfo() function in it under the web root
directory.
When i browse the page, iis report can't find this page. I found a
thing that PHP5.2.2 windows installer automatically add a application
map for iis6 (.php -> c:\php5\\php5isapi.dll). Note that double "\" in
the path. iis can't use this path to analys php script file. The correct
path should be "c:\php5\php5isapi.dll". When I change the map path
manully, the php is working. I think the installer makes a wrong
application map for iis6. Is this the installer's bug?
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=41367&edit=1