ID: 41465
User updated by: clegier at legier dot net
Reported By: clegier at legier dot net
Status: Bogus
Bug Type: Apache2 related
Operating System: Windows XP
PHP Version: 5.2.2
New Comment:
1. Shut down PHP and HTTP.
2. Uninstalled PHP and Apache and deleted folders.
3. Re-installed Apache.
4. Verified HTTP request working within Apache.
5. Downloaded new PHP 5.2.2 from us2.php.net Hurricane Electric.
6. Installed PHP.
7. Configured php.ini-recommended to show correct PATHS. No other
changes made. Renamed to php.ini.
8. Changed Apache httpd.conf to allow PHP.
9. phpinfo(); shows PHP installed and working.
10. Stopped HTTP server.
11. Added extensions:
extension=php_bz2.dll
extension=php_gd2.dll
extension=php_mbstring.dll
extension=php_mcrypt.dll
extension=php_mhash.dll
extension=php_mssql.dll
extension=php_tidy.dll
extension=php_zip.dll
12. Attempted to start HTTP. Received errors.
13. Stopped HTTP.
14. Uninstalled PHP and deleted PHP folder.
15. Downloaded PHP from us.php.net NEXCESS.NET.
16. Installed PHP.
17. Configured php.ini-recommended to show correct PATHS. No other
changes made. Renamed to php.ini.
18. Started HTTP.
19. phpinfo(); shows PHP installed and working.
20. Stopped HTTP server.
21. Added extensions:
extension=php_bz2.dll
extension=php_gd2.dll
extension=php_mbstring.dll
extension=php_mcrypt.dll
extension=php_mhash.dll
extension=php_mssql.dll
extension=php_tidy.dll
extension=php_zip.dll
22. Attempted to start HTTP. Received errors.
I understand you are busy, I understand there are tons of bogus bugs,
irregardless, it didn't work.
Previous Comments:
------------------------------------------------------------------------
[2007-05-22 18:07:23] sniper@php.net
You either have a) old extensions loaded which are not compiled for the
current php version you installed b) mismatching php5ts.dll with
installed extensions / other dlls.
This is not a bug but just bad installation. First make sure you
shutdown everything using PHP, then remove all old dlls, then install
the new ones from the installation zip.
------------------------------------------------------------------------
[2007-05-22 17:25:34] clegier at legier dot net
No relevant information on _safe_erealloc and ap_php_slprintf in
mailing lists.
I am not asking for help on how to install. PHP is installed. Apache
and PHP are configured. (And while at first the php.ini was
misconfigured and had a undesirable output:
http://bugs.php.net/bug.php?id=41463) The above
error is now what I get
when I try to run httpd.
------------------------------------------------------------------------
[2007-05-22 17:12:43] clegier at legier dot net
PHP is installed.
------------------------------------------------------------------------
[2007-05-22 17:09:31] sniper@php.net
Please ask support questions on how to install PHP on the mailing
lists.
------------------------------------------------------------------------
[2007-05-22 17:05:37] clegier at legier dot net
Looking at the phpinfo after receiving these errors the PHP logo and
the Zend logo do not show.
expose_php = On
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/41465--
Edit this bug report at http://bugs.php.net/?id=41465&edit=1