#41578 [Opn->Bgs]: rename isset to is_set

From: Date: Sun, 03 Jun 2007 21:17:37 +0000
Subject: #41578 [Opn->Bgs]: rename isset to is_set
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-113314@lists.php.net to get a copy of this message
ID: 41578 Updated by: johannes@php.net Reported By: Ultrasick at gmx dot de -Status: Open +Status: Bogus Bug Type: Feature/Change Request Operating System: irrelevant PHP Version: 5.2.3 New Comment: Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://www.php.net/manual/ and the instructions on how to report a bug at http://bugs.php.net/how-to-report.php a) isset is no function but a language construct b) we won'T change the name due to BC. Previous Comments: ------------------------------------------------------------------------ [2007-06-03 20:39:11] Ultrasick at gmx dot de Description: ------------ in my opinion the isset function should be renamed to is_set because other is* functions are called is_* for example is_dir is_file is_link is_a at the moment I don't know any other is* function without the underscore ("_"). ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=41578&edit=1

« previous php.bugs (#113314) next »