#40524 [Com]: undefined symbol: zend_qsort
ID: 40524
Comment by: dgrexton at stoofoo dot net
Reported By: mgarner at sunnet dot net
Status: No Feedback
Bug Type: Apache2 related
Operating System: RHEL4
PHP Version: 5.2.1
New Comment:
I'm using apache 2.2.4 and php 5.2.3 and receiving the same error when
trying to start apache. Both were compiled from source, apache was
configured with --enable-so only, while php was configured with
--with-apxs2=/usr/local/apache2/bin/apxs --with-mysql
--with-gd=/usr/lib64 --with-jpeg-dir=/usr/lib64
I'm not sure what other info would help, but here's a uname. If you
need anything else let me know and I'll try to provide it.
Linux sdm 2.6.20-gentoo-r8 #1 SMP Fri Jun 22 15:49:32 PDT 2007 x86_64
AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ AuthenticAMD GNU/Linux
Previous Comments:
------------------------------------------------------------------------
[2007-02-27 01:00:01] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2007-02-19 09:51:45] tony2001@php.net
Can't reproduce.
Please provide more information about your system.
------------------------------------------------------------------------
[2007-02-17 19:06:29] mgarner at sunnet dot net
Description:
------------
Apache 2.2.4 compiles fine as does PHP5.2.1. When apachectl start is
run I get "undefined symbol: zend_qsort"
Actual result:
--------------
Syntax error on line 53 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp5.so into server:
/usr/local/apache2/modules/libphp5.so: undefined symbol: zend_qsort
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=40524&edit=1
Thread (4 messages)