Bug #17827 Updated: PHP 4.2.1 won't load as a DSO for Apache 1.3.26
| From: | zeekamotay at hotmail dot com | Date: | Wed, 19 Jun 2002 16:51:31 +0000 |
| Subject: | Bug #17827 Updated: PHP 4.2.1 won't load as a DSO for Apache 1.3.26 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-11421@lists.php.net to get a copy of this message | ||
ID: 17827
Updated by: zeekamotay@hotmail.com
Reported By: zeekamotay@hotmail.com
Status: Bogus
Bug Type: Apache related
Operating System: Linux 2.2
PHP Version: 4.2.1
New Comment:
I had done that. Since my initial failure, I've tried the same update
on three other similarly-configured machines, and they've all worked
fine. I don't know what the problem could be on the first one, I've
tried four times now with the same result.
Previous Comments:
------------------------------------------------------------------------
[2002-06-19 08:20:24] sander@php.net
You have to recompile PHP _after_ you've upgraded and installed Apache.
Make sure you point to the right apxs executable.
I've just tested it with the 4.3.0-dev and it works fine.
------------------------------------------------------------------------
[2002-06-19 00:27:09] zeekamotay@hotmail.com
I just compiled and installed the new Apache 1.3.26. Configuration,
compilation, and installation of PHP 4.2.1 work fine. However, upon
start of Apache, it fails and I get this message:
API module structure `php4_module' in file
/usr/local/apache/libexec/libphp4.so is garbled - perhaps this is not
an Apache module DSO?
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=17827&edit=1