#41825 [NEW]: Invalid Access to memory Location
| From: | rahulkorlipara at gmail dot com | Date: | Wed, 27 Jun 2007 14:30:34 +0000 |
| Subject: | #41825 [NEW]: Invalid Access to memory Location | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-114340@lists.php.net to get a copy of this message | ||
From: rahulkorlipara at gmail dot com
Operating system: Windows Server 2003 R2
PHP version: 5.2.3
PHP Bug Type: MySQL related
Bug description: Invalid Access to memory Location
Description:
------------
ENVIRONMENT
Windows 2003 Server R2
IIS 6.0
MySQL 5.0.41
PHP 5.2.3
PROBLEM
All extensions except those for mysql working
ERRORS FROM LOG:
[27-Jun-2007 02:59:18] PHP Warning: PHP Startup: Unable to load dynamic
library 'C:\runtimes\php\phpext\php_mysql.dll' - Invalid access to memory
location.
in Unknown on line 0
[27-Jun-2007 02:59:18] PHP Warning: PHP Startup: Unable to load dynamic
library 'C:\runtimes\php\phpext\php_mysqli.dll' - Invalid access to memory
location.
in Unknown on line 0
[27-Jun-2007 02:59:18] PHP Warning: PHP Startup: Unable to load dynamic
library 'C:\runtimes\php\phpext\php_ffi.dll' - The specified module could
not be found.
in Unknown on line 0
ATTEMPTS
- replaced php_mysql.dll & php_mysqli.dll in the ext folder from php 5.2.3
win32 distribution
- extensions folder location provided to the ext folder in php.ini
- provided 'full control' privileges to 'Everyone' to ext folder
- both extensions enables in php.ini
- both php folder and mysql/bin folder in Windows PATH
- Replaced extension dlls with latest several times
- Replaced libmysql.dll several times in the mysql/bin folder
- Did a repair on using MySQL Windows installer
- Restarted IIS as well as Server several times after every change
OTHER PEOPLE WITH THE SAME PROBLEM
http://forums.mysql.com/read.php?11,102233,159429#msg-159429
Reproduce code:
---------------
test.php
<?php
// Connecting, selecting database
$link = mysql_connect('localhost', 'username', 'password')
or die('Could not connect: ' . mysql_error());
echo 'Connected successfully';
mysql_select_db('databasename') or die('Could not select database');
// Performing SQL query
$query = 'SELECT * FROM tablename';
$result = mysql_query($query) or die('Query failed: ' . mysql_error());
// Printing results in HTML
echo "<table>\n";
while ($line = mysql_fetch_array($result, MYSQL_ASSOC)) {
echo "\t<tr>\n";
foreach ($line as $col_value) {
echo "\t\t<td>$col_value</td>\n";
}
echo "\t</tr>\n";
}
echo "</table>\n";
// Free resultset
mysql_free_result($result);
// Closing connection
mysql_close($link);
?>
Expected result:
----------------
"Connected successfully"
the table's contents
Actual result:
--------------
None. Blank page is returned.
--
Edit bug report at http://bugs.php.net/?id=41825&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=41825&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=41825&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=41825&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=41825&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=41825&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=41825&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=41825&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=41825&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=41825&r=support
Expected behavior: http://bugs.php.net/fix.php?id=41825&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=41825&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=41825&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=41825&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=41825&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=41825&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=41825&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=41825&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=41825&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=41825&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=41825&r=mysqlcfg