#41897 [Opn->Fbk]: Loading dynamic library fails although paths and configs are correct
| From: | tony2001@php.net | Date: | Wed, 04 Jul 2007 21:42:48 +0000 |
| Subject: | #41897 [Opn->Fbk]: Loading dynamic library fails although paths and configs are correct | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-114654@lists.php.net to get a copy of this message | ||
ID: 41897
Updated by: tony2001@php.net
Reported By: stefan at viventura dot de
-Status: Open
+Status: Feedback
-Bug Type: Dynamic loading
+Bug Type: Unknown/Other Function
Operating System: Windows Vista Home Premium
PHP Version: 5CVS-2007-07-04 (CVS)
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.2-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.2-win32-installer-latest.msi
Please try clean PHP install first.
Previous Comments:
------------------------------------------------------------------------
[2007-07-04 21:34:16] stefan at viventura dot de
Description:
------------
When I start apache I get the following error:
PHP Warning: PHP Startup: Unable to load dynamic library
'C:/Programme/xampp/php/ext/php_soap.dll' - Die angegebene Prozedur
wurde nicht gefunden. in Unknown on line 0
whereas the german part of the error would be "The specified procedure
could not be found"
The same problem I have with php_imap.dll, php_exif.dll and
php_sqlite.dll. All other extensions (same config, same folders) are
loaded without problems.
Zend extensions are disabled!
Reproduce code:
---------------
I'm using Apache/2.2.4 my php.ini has the following relevant lines:
extension_dir = "C:/Programme/xampp/php/ext/"
extension=php_soap.dll
The folder ext contains among others
php_soap.dll
Expected result:
----------------
There shouldn't be a problem with loading these libs as the folders in
the config are set correctly.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=41897&edit=1