Bug #14198 Updated: build error undefined symbol php_module
| From: | ptaylor at comdt dot uscg dot mil | Date: | Thu, 20 Jun 2002 15:51:40 +0000 |
| Subject: | Bug #14198 Updated: build error undefined symbol php_module | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-11572@lists.php.net to get a copy of this message | ||
ID: 14198
Updated by: ptaylor@comdt.uscg.mil
Reported By: roger.depreeuw@teradyne.com
Status: Bogus
Bug Type: Compile Failure
Operating System: Solaris 2.5.1
PHP Version: 4.0.6
New Comment:
I am using freebsd 4.3, current version of php, apache 1.3.26. I
followed all the steps to compile apache and php, but when I start it
up I am getting this error.
ptay1-ds# /www/bin/apachectl start
Syntax error on line 205 of /www/conf/httpd.conf:
Cannot load /www/libexec/libphp4.so into server:
/www/libexec/libphp4.so: Undefined symbol "core_globals"
/www/bin/apachectl start: httpd could not be started
ptay1-ds#
Why am I getting this error for? Why doesn't php support the current
version of apache 3.x?
Here is all the steps that I followed.
1. gunzip apache_xxx.tar.gz
2. tar -xvf apache_xxx.tar
3. gunzip php-xxx.tar.gz
4. tar -xvf php-xxx.tar
5. cd apache_xxx
6. ./configure --prefix=/www --enable-module=so
7. make
8. make install
9. cd ../php-xxx
10. ./configure --with-mysql --with-apxs=/www/bin/apxs
11. make
12. make install
If you decide to change your configure options after installation
you only need to repeat the last three steps. You only need to
restart apache for the new module to take effect. A recompile of
Apache is not needed.
11. cp php.ini-dist /usr/local/lib/php.ini
You can edit your .ini file to set PHP options. If
you prefer this file in another location, use
--with-config-file-path=/path in step 8.
12. Edit your httpd.conf or srm.conf file and check that these lines
are
present and not commented out:
AddType application/x-httpd-php .php
LoadModule php4_module libexec/libphp4.so
You can choose any extension you wish here. .php is simply the one
we suggest. You can even include .html, and .php3 can be added for
backwards compatibility.
The path on the right hand side of the LoadModule statement must
point
to the path of the PHP module on your system. The above statement is
correct for the steps shown above.
And I also installed all the correct lines in the httpd.conf file. I
need your help please because I am trying to setup this message board,
and php is required.
Thank you
Kernel2
Previous Comments:
------------------------------------------------------------------------
[2001-11-24 18:04:15] sniper@php.net
Ask support questions on the mailing lists:
http://www.php.net/support.php
------------------------------------------------------------------------
[2001-11-23 09:23:01] roger.depreeuw@teradyne.com
make failure using the following configure
configure activate -module=src/modules/php4/libphp.a
Error from make:
Undefined symbol php_module first referenced in file modules.o
ld: fatal: symbol referencing errors. No output written to httpd
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=14198&edit=1