Bug #17881 Updated: Apache will not start after I installed apache & php
| From: | ptaylor2 at comdt dot uscg dot mil | Date: | Thu, 20 Jun 2002 23:33:43 +0000 |
| Subject: | Bug #17881 Updated: Apache will not start after I installed apache & php | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-11624@lists.php.net to get a copy of this message | ||
ID: 17881
Updated by: ptaylor2@comdt.uscg.mil
Reported By: ptaylor@comdt.uscg.mil
Status: Feedback
Bug Type: Apache related
Operating System: Freebsd
PHP Version: 4.2.1
New Comment:
I installed it a few times because php does not support the current
version of apache 2.x, then I deleted the apache and the php directory,
and re-installed them.
Can you please tell me that exact file name or extensions that I need
to delete, or please explain here how I can re-install apache and php
again so it will work.
Thank you
Phillip Taylor
Previous Comments:
------------------------------------------------------------------------
[2002-06-20 19:09:22] sniper@php.net
Did you have any shared extensions installed before?
Any Zend extensions (like the zendoptimizer) ??
Or was this the first time you installed PHP on this machine?
------------------------------------------------------------------------
[2002-06-20 13:09:28] ptaylor@comdt.uscg.mil
This is the error I am getting.
ptay1-ds# /www/bin/apachectl start
Syntax error on line 205 of /www/conf/httpd.conf:
Cannot load /www/libexec/libphp4.so into server:
/www/libexec/libphp4.so: Undefined symbol "core_globals"
/www/bin/apachectl start: httpd could not be started
ptay1-ds#
This is how I installed apache and php and the files that I included in
the httpd.conf file
I followed all of these steps to install the current version of php on
my freebsd server 4.3 and apache 1.3.26.
1. gunzip apache_xxx.tar.gz
2. tar -xvf apache_xxx.tar
3. gunzip php-xxx.tar.gz
4. tar -xvf php-xxx.tar
5. cd apache_xxx
6. ./configure --prefix=/www --enable-module=so
7. make
8. make install
9. cd ../php-xxx
10. ./configure --with-mysql --with-apxs=/www/bin/apxs
11. make
12. make install
If you decide to change your configure options after installation
you only need to repeat the last three steps. You only need to
restart apache for the new module to take effect. A recompile of
Apache is not needed.
11. cp php.ini-dist /usr/local/lib/php.ini
You can edit your .ini file to set PHP options. If
you prefer this file in another location, use
--with-config-file-path=/path in step 8.
12. Edit your httpd.conf or srm.conf file and check that these lines
are
present and not commented out:
AddType application/x-httpd-php .php
LoadModule php4_module libexec/libphp4.so
You can choose any extension you wish here. .php is simply the one
we suggest. You can even include .html, and .php3 can be added for
backwards compatibility.
The path on the right hand side of the LoadModule statement must
point
to the path of the PHP module on your system. The above statement is
correct for the steps shown above.
13. Use your normal procedure for starting the Apache server. (You
must
stop and restart the server, not just cause the server to reload
by
use a HUP or USR1 signal.)
Apache is installed in the /www and I added all the lines as it said in
the docs to the httpd.conf file. Why am I getting this error when I try
and start up appache?
/www/bin/apachectl start
These two lines are in my httpd.conf file
LoadModule php4_module libexec/libphp4.so
AddType application/x-httpd-php .php
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=17881&edit=1