#42389 [Com]: PHP+Apache2+mod_fcgid kills all processes after submit
| From: | crrodriguez at suse dot de | Date: | Fri, 24 Aug 2007 02:52:55 +0000 |
| Subject: | #42389 [Com]: PHP+Apache2+mod_fcgid kills all processes after submit | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-116578@lists.php.net to get a copy of this message | ||
ID: 42389
Comment by: crrodriguez at suse dot de
Reported By: webmaster at machostlink dot net
Status: Feedback
Bug Type: CGI related
Operating System: OSX 10.4.10
PHP Version: 5.2CVS-2007-08-23
New Comment:
what is the value of MaxRequestsPerProcess in your mod_fcgid
configuration, it should be -1
This is a known issue of mod_fcgid see the documentation
http://fastcgi.coremail.cn/doc.htm
This is not a bug in PHP.
Previous Comments:
------------------------------------------------------------------------
[2007-08-23 22:25:37] jani@php.net
My guess is it's crashing so you should try and attach GDB to the
running process and see what the crash is about (note: you need to use
latest CVS snapshot configured using --enable-debug option!)
Make sure you only start 1 PHP FastCGI child, check what it's pid is
and attach gdb:
# gdb /path/to/php-cgi <pid>
------------------------------------------------------------------------
[2007-08-23 22:23:43] jani@php.net
Good point. :)
------------------------------------------------------------------------
[2007-08-23 15:35:57] webmaster at machostlink dot net
Sorry I forgot to add that.. I had a path set but only the path not the
filename. Well so this time PHP did create a log but nothing in it when
the "500 Internal Error" occurs. Well how should it write into the log
when all the processes are killed at once!?
------------------------------------------------------------------------
[2007-08-23 14:13:52] jani@php.net
You forgot to set 'error_log = /path/to/php_error.log'
------------------------------------------------------------------------
[2007-08-23 12:25:06] webmaster at machostlink dot net
Yeah I saw the news "PHP 4 end of life announcement" and I know that
bug reports for it probably won't be fixed unless they are critical
issues. I find it funny that both PHP versions are behaving like
that...
I checked the PHP config for this vhost again and again and tried
different settings:
Right now I have:
------------------
max_execution_time = 60
max_input_time = 120
memory_limit = 64M
error_reporting = E_ALL & ~E_NOTICE
display_errors = On
log_errors = On
log_errors_max_len = 1024
But even after some testing now, still no PHP error.log to be seen!?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/42389
--
Edit this bug report at http://bugs.php.net/?id=42389&edit=1