#42511 [NEW]: When using the CGI SAPI, Zend Extensions fail to load
| From: | schneecrash+php at gmail dot com | Date: | Sat, 01 Sep 2007 18:03:21 +0000 |
| Subject: | #42511 [NEW]: When using the CGI SAPI, Zend Extensions fail to load | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-116960@lists.php.net to get a copy of this message | ||
From: schneecrash+php at gmail dot com
Operating system: OSX, FreeBSD, Linux
PHP version: 5CVS-2007-09-01 (CVS)
PHP Bug Type: CGI related
Bug description: When using the CGI SAPI, Zend Extensions fail to load
Description:
------------
When using the CGI SAPI, Zend Extensions fail to load (and/or?) report as
loaded.
This issue was originally reported as a continuing comment to
"CGI SAPI does not shut down cleanly with -i/-m/-v cmdline options"
http://bugs.php.net/bug.php?id=42453
but that bug was closed nonetheless.
Reproduce code:
---------------
With CLI SAPI:
# php -v
PHP 5.2.5-dev (cli) (built: Aug 31 2007 08:33:23)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
with eAccelerator v0.9.6-dev, Copyright (c) 2004-2007 eAccelerator, by
eAccelerator
with Xdebug v2.1.0-dev, Copyright (c) 2002, 2003, 2004, 2005, 2006,
2007, by Derick Rethans
With CGI SAPI:
# php-cgi -v
PHP 5.2.5-dev (cgi-fcgi) (built: Aug 31 2007 08:34:02)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
Expected result:
----------------
same loading and report of loaded extensions in case of *both* php &
php-cgi
Actual result:
--------------
CLI SAPI loads & reports extensions, CLI SAPI does not
--
Edit bug report at http://bugs.php.net/?id=42511&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=42511&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=42511&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=42511&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=42511&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=42511&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=42511&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=42511&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=42511&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=42511&r=support
Expected behavior: http://bugs.php.net/fix.php?id=42511&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=42511&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=42511&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=42511&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=42511&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=42511&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=42511&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=42511&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=42511&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=42511&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=42511&r=mysqlcfg