#42653 [Opn->Fbk]: mkdir ("foo/bar/") not working
| From: | jani@php.net | Date: | Thu, 11 Oct 2007 13:54:28 +0000 |
| Subject: | #42653 [Opn->Fbk]: mkdir ("foo/bar/") not working | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-118403@lists.php.net to get a copy of this message | ||
ID: 42653
Updated by: jani@php.net
Reported By: xavier at sdv dot fr
-Status: Open
+Status: Feedback
Bug Type: Directory function related
Operating System: linux
PHP Version: 5.2.4
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.2-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.2-win32-installer-latest.msi
Previous Comments:
------------------------------------------------------------------------
[2007-10-01 12:27:28] xavier at sdv dot fr
Sorry for the delay, I was on holydays
OS : fedora core 2, kernel 2.6.10 SMP
Apache/1.3.37
------------------------------------------------------------------------
[2007-09-19 10:31:54] jani@php.net
Exactly what OS is this? (linux kernel version, distro, etc..)
------------------------------------------------------------------------
[2007-09-13 17:10:29] xavier at sdv dot fr
Open basedir and safe mode are in effect, as you can see in the
phpinfo
But they are not relevent. The mkdir fails within the allowed path,
with corrects uid/gid.
If it was an open_basedir or safe_mode problem, mkdir("foo") whould
fail like mkdir("foo/"). But this is not the case. mkdir("foo") works,
mkdir("foo/") doesn't.
I even try the code with de CLI and a void php.ini, I have the same
error.
With exactly the same configuration and PHP 5.2.3, both mkdir("foo")
and mkdir("foo/") are working
------------------------------------------------------------------------
[2007-09-13 15:14:29] iliaa@php.net
Do you have open_basedir and/or safe_mode enabled?
------------------------------------------------------------------------
[2007-09-13 13:00:40] xavier at sdv dot fr
The bug is occuring with mod_php against apache 1.3.37
I have the same problem with the CLI version
You can consult our phpinfo() :
http://212.95.67.51/ and our php.ini
http://212.95.67.51/php.ini
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/42653
--
Edit this bug report at http://bugs.php.net/?id=42653&edit=1