#28708 [Com]: move_uploaded_file to no Permission dir make php crash
| From: | ayo at p-ims dot co dot uk | Date: | Thu, 11 Oct 2007 17:27:17 +0000 |
| Subject: | #28708 [Com]: move_uploaded_file to no Permission dir make php crash | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-118419@lists.php.net to get a copy of this message | ||
ID: 28708
Comment by: ayo at p-ims dot co dot uk
Reported By: xuefer at 21cn dot com
Status: No Feedback
Bug Type: Filesystem function related
Operating System: *
PHP Version: 5CVS, 4CVS
Assigned To: helly
New Comment:
When on a virtual server with apache2handler loaded, apache becomes the
user / owner of the file and does not have permissions to the directory.
get_current_user() does not report the file owner but the script
owner.
How can this be solved? Making the target directory writable by the
world revealed this bug.
Previous Comments:
------------------------------------------------------------------------
[2005-11-17 14:37:37] arun_ri2003 at rediffmail dot com
Hi,
I also get this problem plz help us.If you have any solution then
report us
Thanks
Arun Goyal
------------------------------------------------------------------------
[2005-11-17 14:32:33] arun_ri2003 at rediffmail dot com
I can't get the file uploader to work. This is the error I get:
Warning: move_uploaded_file(../img/mainpict.jpg)
[function.move-uploaded-file]: failed to open stream: Permission denied
in
/usr/local/share/doc/vhost/privatebazaar.com/httpdocs/property/editpropimg.php
on line 50
Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to
move '/users/privatebazaar.com/tmp/phpI5aoQZ' to '../img/mainpict.jpg'
in
/usr/local/share/doc/vhost/privatebazaar.com/httpdocs/property/editpropimg.php
on line 50
------------------------------------------------------------------------
[2004-11-02 01:00:05] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2004-10-25 09:39:15] helly@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5-win32-latest.zip
------------------------------------------------------------------------
[2004-07-06 16:05:27] sniper@php.net
Marcus, this is once again one of those weird bugs caused by your
docref crap.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/28708
--
Edit this bug report at http://bugs.php.net/?id=28708&edit=1