ID: 43038
Updated by: dmitry@php.net
Reported By: mike dot simonds at maxim-ic dot com
-Status: Assigned
+Status: Feedback
Bug Type: SOAP related
Operating System: Windows XP & Linux
PHP Version: 5.2CVS-2007-10-22
Assigned To: dmitry
New Comment:
Sorry, but could you please provide a complete example that
demonstrates the bug and doesn't require your password.
Previous Comments:
------------------------------------------------------------------------
[2007-10-23 09:26:17] jani@php.net
Assigned to the SOAP extension maintainer.
------------------------------------------------------------------------
[2007-10-22 13:21:50] mike dot simonds at maxim-ic dot com
We tried a CVS version for both Linux and Windows on Sunday and still
received the same error/fault
Thanks,
Mike
------------------------------------------------------------------------
[2007-10-22 08:15:14] jani@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.2-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.2-win32-installer-latest.msi
------------------------------------------------------------------------
[2007-10-19 14:00:10] mike dot simonds at maxim-ic dot com
Description:
------------
I have a set of scripts which connect to Salesforce.com's API and
retrieve data from our instance and stores them in either an Oracle
Database or MySQL. These scripts are identical, just the retrieving SQL
statement is different. The Memory leak error happens when the scripts
with large data sets perform the extract. The reason that I am
reporting this bug is that these scripts performed flawlessly in all php
version 5.* prior to upgrading to 5.2.1 and up. The servers that house
these scripts are currently running 5.2.0
Reproduce code:
---------------
source of code > http://www.mikesimonds.com/soap_php_bug.phps
Expected result:
----------------
I expected the data to be retrieved and inserted into our target
database without any errors as it did with versions prior to 5.2.1.
These data sets number in the 130,000 count and have 40-60 rows in each
table
Actual result:
--------------
Error Results:
Fatal error: Uncaught SoapFault exception: [Client] Allowed memory size
of 134217728 bytes exhausted (tried to allocate 1856074 bytes) in
C:\wamp\www\includes\soapclient\SforceBaseClient.php:506 Stack trace: #0
[internal function]: SoapClient->__call('queryMore', Array) #1
C:\wamp\www\includes\soapclient\SforceBaseClient.php(506):
SoapClient->queryMore(Object(stdClass)) #2
C:\wamp\www\extract\export_product2.php(122):
SforceBaseClient->queryMore('01g40000001pM0w...') #3
C:\wamp\www\extract\export_product2.php(28):
get_products(Object(SforcePartnerClient)) #4 {main} thrown in
C:\wamp\www\includes\soapclient\SforceBaseClient.php on line 506
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=43038&edit=1