#43284 [NEW]: Error "undefined symbol: zend_qsort" while starting Apache
| From: | marplatense at ubuntu dot com | Date: | Wed, 14 Nov 2007 01:40:07 +0000 |
| Subject: | #43284 [NEW]: Error "undefined symbol: zend_qsort" while starting Apache | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-119620@lists.php.net to get a copy of this message | ||
From: marplatense at ubuntu dot com
Operating system: CentOS 4 64 bits
PHP version: 5.2.5
PHP Bug Type: Apache2 related
Bug description: Error "undefined symbol: zend_qsort" while starting Apache
Description:
------------
This bug is equal to http://bugs.php.net/bug.php?id=40524 (but it has a
different php version and that's why I fill it again).
Reproduce code:
---------------
1- Using Apache/2.0.52 installed from CentOS repositories (updated
Nov,13,2007)
2- PHP 5.2.5 compiled from source using this options:
./configure --prefix=/opt/php/php5.2.5 --exec-prefix=/opt/php/php5.2.5
--with-config-file-path=etc/httpd/conf.d --with-libdir=lib64 --with-gd
--with-zlib=/usr --with-xmlrpc
--with-oci8=/opt/oracle/orase/oracle/product/10.2.0/db_1
--with-apxs2=/usr/sbin/apxs --enable-sigchild --with-ttf=/usr/lib64
--enable-gd-native-ttf --enable-gd-imgstrttf --enable-gd-native-ttf
--with-ttf-dir=/usr/local/lib --with-freetype-dir=/opt/freetype
--with-zlib-dir=/usr/local/lib --with-png-dir=/usr/local/lib
--with-jpeg-dir=/usr/local/lib --with-imap=/opt/imap/ --with-imap-ssl
--with-mysql=/usr/bin --enable-mbstring --with-iconv --with-zlib
--enable-sockets
3- Trying to start Apache:
# apachectl start
Expected result:
----------------
Apache starting ok.
Actual result:
--------------
Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /usr/lib64/httpd/modules/libphp5.so into server:
/usr/lib64/httpd/modules/libphp5.so: undefined symbol: zend_qsort
This is my /etc/httpd/conf.d/php.conf
***********************
#
# PHP is an HTML-embedded scripting language which attempts to make it
# easy for developers to write dynamically generated webpages.
#
LoadModule php5_module /usr/lib64/httpd/modules/libphp5.so
#
# Cause the PHP interpreter to handle files with a .php extension.
#
AddType application/x-httpd-php .php .phtml
AddType application/x-httpd-php-source .phps
#
# Add index.php to the list of files that will be served as directory
# indexes.
#
DirectoryIndex index.php
***********************
--
Edit bug report at http://bugs.php.net/?id=43284&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=43284&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=43284&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=43284&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=43284&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=43284&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=43284&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=43284&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=43284&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=43284&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=43284&r=support
Expected behavior: http://bugs.php.net/fix.php?id=43284&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=43284&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=43284&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=43284&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=43284&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=43284&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=43284&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=43284&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=43284&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=43284&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=43284&r=mysqlcfg