Bug #17944 Updated: ./configuring with GD and jpeg/png

From: Date: Tue, 25 Jun 2002 15:38:05 +0000
Subject: Bug #17944 Updated: ./configuring with GD and jpeg/png
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-12053@lists.php.net to get a copy of this message
ID: 17944 Updated by: sniper@php.net Reported By: potnoddle@hotmail.com -Status: Open +Status: Feedback Bug Type: GD related Operating System: solaris 8 PHP Version: 4.1.2 New Comment: Let us know in any case.. Previous Comments: ------------------------------------------------------------------------ [2002-06-25 04:25:04] potnoddle@hotmail.com found this only when i redirected the out of configure, solaris comes with gcc 2.9.1 as a defualt! this may work, will hear back from me if it has'nt *** Warning: Releases of GCC earlier than version 3.0 cannot reliably *** create self contained shared libraries on Solaris systems, without *** introducing a dependency on libgcc.a. Therefore, libtool is disabling *** -no-undefined support, which will at least allow you to build shared *** libraries. However, you may find that when you link such libraries *** into an application without using GCC, you have to manually add *** gcc --print-libgcc-file-name to the link command. We urge you to *** upgrade to a newer version of GCC. Another option is to rebuild your *** current GCC to use the GNU linker from GNU binutils 2.9.1 or newer. ------------------------------------------------------------------------ [2002-06-24 14:07:29] sniper@php.net Is that libgcc_s.so.1 anywhere in your system? (try 'find / -name libgss_s.so.1') And was this with 4.2.1? ------------------------------------------------------------------------ [2002-06-24 12:30:12] potnoddle@hotmail.com i've tryed the latest versions get more but only this httpd starting. Syntax error on line 236 of /etc/apache/httpd.conf: Cannot load /usr/apache/libexec/libphp4.so into server: ld.so.1: /usr/apache/bin/httpd: fatal: libgcc_s.so.1: open failed: No such file or directory /usr/apache/bin/apachectl start: httpd could not be started i can't find libgcc_s.so ??? ------------------------------------------------------------------------ [2002-06-24 10:16:19] sniper@php.net This should be fixed in PHP 4.2.1, so please try it first. ------------------------------------------------------------------------ [2002-06-24 08:59:10] sander@php.net It seems your libjpeg is broken. Reinstall it. Also, try the latest version of PHP, I think lots has been changed since 4.1.x (even better: try a CVS version from http://snaps.php.net) ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/17944 -- Edit this bug report at http://bugs.php.net/?id=17944&edit=1

« previous php.bugs (#12053) next »