#43598 [NEW]: Patch for Bug #41561 breaks ini_set()
| From: | birne at 007mail dot de | Date: | Fri, 14 Dec 2007 18:14:01 +0000 |
| Subject: | #43598 [NEW]: Patch for Bug #41561 breaks ini_set() | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-120652@lists.php.net to get a copy of this message | ||
From: birne at 007mail dot de
Operating system: irrelevant
PHP version: 5.2.5
PHP Bug Type: Unknown/Other Function
Bug description: Patch for Bug #41561 breaks ini_set()
Description:
------------
The Author of Bug #41561 wrote:
<quote>
When I set a value inside the httpd.conf with php_admin_value or
php_admin_flag that is INI_ALL or INI_PERDIR it can be overwritten at
runtime using ini_set()
I don't think this should be possible. But the documentation on this
problem doesn't assure me if this is a bug or a feature!
</quote>
Unfortunately, his question was neither discussed nor answered. Also I
disagree that is should not be possible re-setting the value of a INI_ALL
configuration directive with ini_set().
According to http://www.php.net/manual/en/ini.php
PHP_INI_ALL means "Entry
can be set anywhere". In my opinion this mutually includes "Entry can be
changed anywhere".
Currently setting e.g. the include_path using ini_set('include_path', ..)
or set_include_path(..) will fail when there is a php_admin_value
include_path directive in the apache configuration. The include_path is a
PHP_INI_ALL directive.
Reproduce code:
---------------
Set in apaches https.conf
php_admin_value include_path .:/usr/share/php:/server/wide/libs/
and the run
if (!set_include_path(get_include_path().PATH_SEPARATOR.'local/libs/')) {
echo 'set_include_path() failed';
} else {
echo get_include_path();
}
Expected result:
----------------
.:/usr/share/php:/server/wide/libs/:local/libs/
Actual result:
--------------
set_include_path() failed
--
Edit bug report at http://bugs.php.net/?id=43598&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=43598&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=43598&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=43598&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=43598&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=43598&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=43598&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=43598&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=43598&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=43598&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=43598&r=support
Expected behavior: http://bugs.php.net/fix.php?id=43598&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=43598&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=43598&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=43598&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=43598&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=43598&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=43598&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=43598&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=43598&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=43598&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=43598&r=mysqlcfg