#43764 [Opn->Asn]: Installer Uses old DOS format Path, Causing 404 Errors
| From: | tony2001@php.net | Date: | Sat, 12 Jan 2008 15:39:48 +0000 |
| Subject: | #43764 [Opn->Asn]: Installer Uses old DOS format Path, Causing 404 Errors | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-121229@lists.php.net to get a copy of this message | ||
ID: 43764
Updated by: tony2001@php.net
Reported By: jake67890 at hotmail dot com
-Status: Open
+Status: Assigned
Bug Type: IIS related
Operating System: Windows 2003
PHP Version: 5.2.5
-Assigned To:
+Assigned To: jmertic
Previous Comments:
------------------------------------------------------------------------
[2008-01-06 05:05:45] jake67890 at hotmail dot com
Description:
------------
This is an issue with the Windows installer.
Using all defaults with the installer for 5.2.5 on Windows 2003 sets
the IIS application map path to C:\PROGRA~1\PHP\PHP5IS~1.DLL. IIS does
not seem to like this DOS format path and returns a 404 error for every
PHP page request, regardless of whether the php file exists or not.
Changing the value to "C:\Program Files\PHP\php5isapi.dll" (including
surrounding quotes) seems to resolve the issue.
Reproduce code:
---------------
Run the Windows Installer on Windows 2003 accepting all defaults.
Expected result:
----------------
IIS should be able to serve a simple test PHP page.
Actual result:
--------------
IIS Displays a 404 error regardless of whether the php file exists or
not.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=43764&edit=1