Bug #13499 Updated: imap_open fails to authenticate
| From: | sniper@php.net | Date: | Thu, 27 Jun 2002 03:01:48 +0000 |
| Subject: | Bug #13499 Updated: imap_open fails to authenticate | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-12193@lists.php.net to get a copy of this message | ||
ID: 13499
Updated by: sniper@php.net
Reported By: pc@philiptcarey.com
-Status: Open
+Status: Bogus
Bug Type: IMAP related
Operating System: linux (mandrake 2.4.8-24mdk)
PHP Version: 4.0.6
New Comment:
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php
If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
also, try adding /notls after the port:
$port = ":143/imap/notls";
Previous Comments:
------------------------------------------------------------------------
[2001-10-09 20:47:29] pc@philiptcarey.com
I tested the same code, this time using the php4.04 rpms, but the same
version of linux (Mandrake 8.1) and apache (1.3.2), and it worked
correctly.
There really does seem to be a bug that affects the php-imap that was
introduced between 4.04 and 4.06.
Is there any plan to look at this, and if not can someone provide some
pointers on how to do a 4.04 install in my current environment. I seem
to get into a long trail of dependencies, and am not able to get the
config that I need.
Thanks.
------------------------------------------------------------------------
[2001-10-02 15:47:42] pc@philiptcarey.com
Review of mail server logs and further testing against two different
imap servers indicates that the proximal cause of the problem is an
incorrect authentication scheme (though I suspect a different root
cause, ie, memory overwrite, etc.).
It is as if there should be a specification associated with the
authentication request which indicates md5-cram or plaintext, but that
is either not sent or garbled.
------------------------------------------------------------------------
[2001-10-01 13:45:29] pc@philiptcarey.com
PHP 4.06 Code which works on apache 1.3.2 on Win2k fails on linux with
the same versions of PHP and apache. Depending on the extensions which
are enabled either output terminates completely, or if the only enabled
extension is imap then authentication fails. Code shown:
$server = "bluetrain.com";
$port = ":143/imap";
$account = "pcarey@bluetrain.com";
$passwd = "x0x0x0"; // not really...
$connstr = '\{' . $server . $port . '}' . imap_utf7_encode($mailbox);
$connstr = "\{$server$port}" . imap_utf7_encode($mailbox);
$mbox = imap_open ($connstr, $account, $passwd)
or die(imap_last_error ());
Seems like this would have been noticed by the folks that do horde,
since horde will not work and fails with the same behavior.
A variety of servers, accounts, syntaxes have been attempted, but it is
never possible to authenticate from linux, apache 1.3.2 php4.06.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=13499&edit=1