#44185 [Csd]: Unable to start a session twice with custom session handler.

From: Date: Fri, 07 Mar 2008 23:30:46 +0000
Subject: #44185 [Csd]: Unable to start a session twice with custom session handler.
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-123040@lists.php.net to get a copy of this message
ID: 44185 Updated by: gwynne@php.net Reported By: kukulich at kukulich dot net Status: Closed Bug Type: Session related Operating System: Windows XP, Linux PHP Version: 5.2.5 New Comment: This bug has been fixed in CVS. Snapshots of the sources are packaged every three hours; this change will be in the next snapshot. You can grab the snapshot at http://snaps.php.net/. Thank you for the report, and for helping us make PHP better. Previous Comments: ------------------------------------------------------------------------ [2008-02-20 17:40:01] gwynne@php.net This is a duplicate of bug #32330. For those following this bug, my patch to fix it is at: http://www.wanderingknights.org/maryoku/bug32330-HEAD.diff http://www.wanderingknights.org/maryoku/bug32330-PHP_5_3.diff ------------------------------------------------------------------------ [2008-02-20 14:10:15] kukulich at kukulich dot net Description: ------------ Unable to start a session on a second time when using custom session handler. Tested with the same results on PHP 5.1, 5.2, 5.2 CVS versions, both Windows AND Linux Reproduce code: --------------- Source code on http://temp.kukulich.net/session.php.txt Expected result: ---------------- I expected that the example will work without any error. Actual result: -------------- Fatal error: session_start(): Failed to initialize storage module: user (path: C:/Program Files/Apache2/temp) in P:\Projekty\Test\session\session.php on line 9 ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=44185&edit=1

« previous php.bugs (#123040) next »