#43677 [Opn->Csd]: Inconsistent behaviour of include_path set with php_value
| From: | iliaa@php.net | Date: | Thu, 13 Mar 2008 16:01:53 +0000 |
| Subject: | #43677 [Opn->Csd]: Inconsistent behaviour of include_path set with php_value | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-123297@lists.php.net to get a copy of this message | ||
ID: 43677
Updated by: iliaa@php.net
Reported By: root at net1 dot cc
-Status: Open
+Status: Closed
Bug Type: Safe Mode/open_basedir
Operating System: FreeBSD 6.2
PHP Version: 5.2.5
New Comment:
This bug has been fixed in CVS.
Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
Thank you for the report, and for helping us make PHP better.
Previous Comments:
------------------------------------------------------------------------
[2008-03-13 15:51:56] manuel at mausz dot at
ping
------------------------------------------------------------------------
[2008-03-07 20:21:13] oliver dot graetz at gmx dot de
In order to avoid getting my report marked as a duplicate of this one:
I have experienced a similar problem with PHP 5.2.5. I am using
set_include_path() but the PHP ignores the call and uses the value
defined in the main php.ini file.
------------------------------------------------------------------------
[2008-02-26 12:22:18] manuel at mausz dot at
Yes. The bug only occurs if you're mixing php_admin_value and php_value
with the same ini-setting.
------------------------------------------------------------------------
[2008-02-26 11:18:06] admin at scuolacomunicazioneiulm dot it
I've exactly the same system of [ryan at djurovich dot com]
Plesk 8.3.0
CentOS 4
linux 2.6.9-023stab033.9-enterprise
apache 2.0.52-32.3
php 5.2.5-4
updated this night :( (oh, don't I could sleep, don't?!)
I think this bug is going to become so much serious as Plesk users
update their systems!
Error could be seen in www.fondazioneiulm.it and
www.scuolacomunicazioneiulm.it. These sites are both built on Zend
Framework, like [it at inmolinkmls dot com] application. Some request
load Zend/Loader.php, some not (but I have "display_errors = off", so
you'll see a blank page instead of error).
Do you think that the hack to change php_admin_value to php_value in
Plesk confs could patch this kind of situation?
MP
------------------------------------------------------------------------
[2008-02-25 05:39:06] ryan at djurovich dot com
Confirmed, running server with Plesk 8.3.0:
CentOS 4
linux 2.6.9-023stab033.9-enterprise
apache 2.0.52-32.3
php 5.2.5-4
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/43677
--
Edit this bug report at http://bugs.php.net/?id=43677&edit=1