#44588 [NEW]: Problem with module php_imagick.dll
| From: | amudhanst at gmail dot com | Date: | Tue, 01 Apr 2008 10:57:53 +0000 |
| Subject: | #44588 [NEW]: Problem with module php_imagick.dll | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-123818@lists.php.net to get a copy of this message | ||
From: amudhanst at gmail dot com
Operating system: Window XP
PHP version: 5.2.5
PHP Bug Type: Dynamic loading
Bug description: Problem with module php_imagick.dll
Description:
------------
I have configured Apache2.2, PHP5.2.5(Windows Installer). In the installer
I didn't find php_imagick.dll which is the extension for ImageMagick. I
downloaded from the PECL extensions in php.net site. There I found the file
and copied to the php/ext folder and configured the php.ini file to enable
this extension. But it says the following error
PHP Startup: Unable to load dynamic library 'D:\PHP\ext\php_imagick.dll' -
The specified module could not be found.
Reproduce code:
---------------
;;;;This is the configuration I am having for extensions in my php.ini
; Directory in which the loadable extensions (modules) reside.
extension_dir ="D:\PHP\ext"
;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;
;extension=php_xsl.dll
;extension=php_zip.dll
extension=php_imagick.dll
Expected result:
----------------
The extension cannot be loaded. and says the following error
PHP Startup: Unable to load dynamic library 'D:\PHP\ext\php_imagick.dll' -
The specified module could not be found.
--
Edit bug report at http://bugs.php.net/?id=44588&edit=1
--
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=44588&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=44588&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=44588&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=44588&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=44588&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=44588&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=44588&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=44588&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=44588&r=support
Expected behavior: http://bugs.php.net/fix.php?id=44588&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=44588&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=44588&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=44588&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=44588&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=44588&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=44588&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=44588&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=44588&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=44588&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=44588&r=mysqlcfg