#45328 [NEW]: post_max_size of 6144M of greater causes $_POST to fail
| From: | corry dot gellatly at ncl dot ac dot uk | Date: | Sat, 21 Jun 2008 19:06:40 +0000 |
| Subject: | #45328 [NEW]: post_max_size of 6144M of greater causes $_POST to fail | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-125930@lists.php.net to get a copy of this message | ||
From: corry dot gellatly at ncl dot ac dot uk
Operating system: Linux (Fedora Core 8)
PHP version: 5.2.6
PHP Bug Type: Session related
Bug description: post_max_size of 6144M of greater causes $_POST to fail
Description:
------------
Setting post_max_size to a value of 6144M or greater causes $_POST to
fail, for example to log in and start a session with the simple code below:
<?php
session_start();
$username = $_POST['username'];
$password = $_POST['password'];
...etc.
?>
It will also cause the login to phpMyAdmin to fail with the error
message:
Warning: Unknown: POST Content-length of 81 bytes exceeds the limit of
-2147483648 bytes in Unknown on line 0
At a guess, perhaps to due to the post_max_size variable type? Although
6144M is perhaps an excessive post size maximum, a comment in the php.ini
file warning of the maximum limit would be helpful.
Reproduce code:
---------------
Can be reproduced with the index.php page of phpMyAdmin 2.10.0.2 and above
Expected result:
----------------
Failed login when post_max_size >= 6144M
--
Edit bug report at http://bugs.php.net/?id=45328&edit=1
--
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=45328&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=45328&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=45328&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=45328&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=45328&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=45328&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=45328&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=45328&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=45328&r=support
Expected behavior: http://bugs.php.net/fix.php?id=45328&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=45328&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=45328&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=45328&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=45328&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=45328&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=45328&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=45328&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=45328&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=45328&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=45328&r=mysqlcfg