#31050 [Com]: SOAP class will not parse WSDL file located on a secure HTTPS connection
| From: | john at soundreal dot co dot uk | Date: | Mon, 07 Jul 2008 17:29:21 +0000 |
| Subject: | #31050 [Com]: SOAP class will not parse WSDL file located on a secure HTTPS connection | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-126344@lists.php.net to get a copy of this message | ||
ID: 31050
Comment by: john at soundreal dot co dot uk
Reported By: dylanwoster at mac dot com
Status: No Feedback
Bug Type: SOAP related
Operating System: Mac OS X 10.3.6
PHP Version: 5.0.2
Assigned To: dmitry
New Comment:
I've cracked this, problem was with my php configuration. Needed to
recompile using
-with-openssl
now working fine on Mac os 10.4.11 with php 5.2.6
Previous Comments:
------------------------------------------------------------------------
[2008-06-19 14:22:57] trippinbilly25 at gmail dot com
I have solved this problem on Windows XP by replacing the following
.dll files in the System32 folder with their versions located in the php
folder:
libeay.dll
ssleay32.dll
For some reason an error was logged in my Apache error log that said
OpenSSL was not being loaded, replacing these files solved the problem
for me.
------------------------------------------------------------------------
[2008-04-22 15:20:14] pejusdas at gmail dot com
I'm having the same problem with a linux box running php 5.2.5 and a
win xp box running the same version. Has anybody found the solution for
this problem yet? Thanks.
Pejus
------------------------------------------------------------------------
[2008-04-02 01:03:16] jfarhat at kirkhamsystems dot com
I am also having the same problem in PHP 5.2.5. the procedure code at
the end of the message works for HTTP but fails with HTTPS with the
message:
SOAP-ERROR: Parsing WSDL: Couldn't load from
'https://arcweb.esri.com/services/v2/Authentication.wsdl'
....
Reproduce code:
---------------
$client = new SoapClient(
"https://arcweb.esri.com/services/v2/Authentication.wsdl"
);
echo( $client->getVersion( ) );
------------------------------------------------------------------------
[2008-01-23 04:31:10] marcus dot uy at virtualthinking dot com
Hi,
Having similar problem on Windows XP Pro:
Apache 2.2.8
PHP 5.2.5
OpenSSL 0.9.8g
In my case the connectiion works once, then fails on the next
connection attempt. I then have to restart apache because the
soapserver becomes completely unresponsive.
------------------------------------------------------------------------
[2008-01-03 13:08:19] php at eflow dot dk
I have the problem too, on Gentoo Linux.
Apache 2.2.6
PHP 5.2.5
OpenSSL 0.9.8g
Configuration:
'./configure' '--prefix=/usr/lib/php5' '--host=i686-pc-linux-gnu'
'--mandir=/usr/lib/php5/man' '--infodir=/usr/lib/php5/info'
'--sysconfdir=/etc' '--cache-file=./config.cache' '--disable-cli'
'--with-apxs2=/usr/sbin/apxs2'
'--with-config-file-path=/etc/php/apache2-php5'
'--with-config-file-scan-dir=/etc/php/apache2-php5/ext-active'
'--without-pear' '--disable-bcmath' '--with-bz2'
'--disable-calendar'
'--with-curl' '--with-curlwrappers' '--disable-dbase'
'--disable-exif'
'--without-fbsql' '--without-fdftk' '--disable-filter'
'--disable-ftp'
'--with-gettext' '--without-gmp' '--disable-hash'
'--disable-json'
'--without-kerberos' '--enable-mbstring' '--with-mcrypt'
'--without-mhash' '--without-msql' '--without-mssql'
'--with-ncurses'
'--with-openssl' '--with-openssl-dir=/usr' '--disable-pcntl'
'--disable-pdo' '--without-pgsql' '--disable-posix'
'--with-pspell'
'--without-recode' '--disable-shmop' '--without-snmp'
'--enable-soap'
'--disable-sockets' '--without-sybase' '--without-sybase-ct'
'--disable-sysvmsg' '--disable-sysvsem' '--disable-sysvshm'
'--without-tidy' '--disable-wddx' '--with-xmlrpc'
'--with-xsl'
'--enable-zip' '--with-zlib' '--disable-debug'
'--enable-dba'
'--without-cdb' '--with-db4' '--without-flatfile'
'--with-gdbm'
'--without-inifile' '--without-qdbm' '--with-freetype-dir=/usr'
'--with-t1lib=/usr' '--disable-gd-jis-conv' '--with-jpeg-dir=/usr'
'--with-png-dir=/usr' '--without-xpm-dir' '--with-gd'
'--with-ldap'
'--with-ldap-sasl' '--with-mysql=/usr'
'--with-mysql-sock=/var/run/mysqld/mysqld.sock'
'--with-mysqli=/usr/bin/mysql_config' '--with-readline'
'--without-libedit' '--without-mm' '--with-sqlite=/usr'
'--enable-sqlite-utf8'
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/31050
--
Edit this bug report at http://bugs.php.net/?id=31050&edit=1