#42089 [Com]: erro blob firebird php
| From: | voev at vilex dot cc | Date: | Sat, 19 Jul 2008 22:18:30 +0000 |
| Subject: | #42089 [Com]: erro blob firebird php | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-126997@lists.php.net to get a copy of this message | ||
ID: 42089
Comment by: voev at vilex dot cc
Reported By: anita dot sobreira at gmail dot com
Status: No Feedback
Bug Type: InterBase related
Operating System: fedora 6
PHP Version: 5.2.3
New Comment:
This bug really persists in 64 bit linux.
(on Linux-32 works)
Previous Comments:
------------------------------------------------------------------------
[2007-08-28 15:10:30] ale dot pas at tiscali dot it
The problem is still there in 5.2.3, please reopen this bug.
Tested on linux 64bit.
Configure:
./configure --with-interbase=/opt/firebird
--with-config-file-path=/etc \
--with-apxs2=/usr/sbin/apxs2 \
--with-gd=/usr/lib64 \
--includedir=/usr/include \
--enable-fastcgi \
--with-gettext \
--with-mysql=/usr/local/lib/mysql/ \
--with-openssl_dir=/usr/include/openssl \
--with-curl \
--with-curlwrappers \
--with-zlib \
--without-pear
------------------------------------------------------------------------
[2007-08-03 01:00:00] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2007-07-26 09:52:30] jani@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.2-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.2-win32-installer-latest.msi
------------------------------------------------------------------------
[2007-07-24 16:00:31] anita dot sobreira at gmail dot com
Description:
------------
error in make test
and after error in blob with php 5.2.3 and firebird
i test with php 5.2.2 , 5.2.1
firebirdCS 1.5 and 2.0 ever a have the same error
i am use fedora 6
i test in red hat entreprise 4 and i have the same error
my selinux is disabled
Reproduce code:
---------------
when i did the "make test"
it show this error
=====================================================================
FAILED TEST SUMMARY
---------------------------------------------------------------------
double to string conversion tests [Zend/tests/double_to_string.phpt]
Bug #16069 (ICONV transliteration failure)
[ext/iconv/tests/bug16069.phpt]
iconv stream filter [ext/iconv/tests/iconv_stream_filter.phpt]
InterBase: connect, close and pconnect [ext/interbase/tests/002.phpt]
InterBase: misc sql types (may take a while)
[ext/interbase/tests/003.phpt]
InterBase: BLOB test [ext/interbase/tests/004.phpt]
InterBase: transactions [ext/interbase/tests/005.phpt]
InterBase: binding (may take a while) [ext/interbase/tests/006.phpt]
InterBase: array handling [ext/interbase/tests/007.phpt]
InterBase: event handling [ext/interbase/tests/008.phpt]
Bug #22414 (passthru() does not read data correctly)
[ext/standard/tests/file/bug22414.phpt]
strripos() offset integer overflow
[ext/standard/tests/strings/strripos_offset.phpt]
XMLWriter: libxml2 XML Writer, Elements & Attributes
[ext/xmlwriter/tests/007.phpt]
XMLWriter: libxml2 XML Writer, Elements & Attributes
[ext/xmlwriter/tests/OO_007.phpt]
=====================================================================
after when i test with php page I had this warning
Warning: ibase_blob_info() [function.ibase-blob-info]: invalid BLOB ID
in /var/www/html/internet/intranet/novo/marketing/solVisualizar.php on
line 143
Warning: ibase_blob_open() [function.ibase-blob-open]: invalid BLOB ID
in /var/www/html/internet/intranet/novo/marketing/solVisualizar.php on
line 144
Warning: ibase_blob_get(): supplied argument is not a valid Interbase
blob resource in
/var/www/html/internet/intranet/novo/marketing/solVisualizar.php on line
146
Warning: ibase_blob_close(): supplied argument is not a valid Interbase
blob resource in
/var/www/html/internet/intranet/novo/marketing/solVisualizar.php on line
148
my configure is this
./configure --with-apxs2=/usr/local/apache2/bin/apxs
--with-mysql=/usr/lib/mysql --with-interbase=/opt/firebird
--with-jpeg-dir=/usr --enable-sockets --prefix=/usr
--sysconfdir=/etc/php --with-mod_charset --localstatedir=/var
--with-config-file-path=/etc/php --with-config-file-scan-dir=/etc/php
--disable-debug --enable-pic --enable-dbase --disable-rpath
--enable-inline-optimization --with-bz2 --with-db4 --with-curl
--with-freetype-dir=/usr --enable-gd-native-ttf --without-gdbm
--with-gettext --without-gmp --with-iconv --with-openssl --with-pspell
--with-xml --with-expat-dir=/usr --with-zlib --with-layout=GNU
--enable-bcmath --enable-exif --enable-ftp --enable-magic-quotes
--enable-safe-mode --enable-sockets --enable-shmop --enable-sysvmsg
--enable-track-vars --enable-trans-sid --disable-yp --enable-wddx
--with-pear --enable-memory-limit --enable-calendar --enable-dbx
--enable-dio --with-mime-magic --with-pgsql=/usr/local/pgsql
--enable-embed --with-readline --enable-gd-jis-conv --enable-fastcgi
--enable-discard-path --enable-force-cgi-redirect --enable-dba --with-gd
--with-jpeg-dir=/usr --with-png-dir=/usr --prefix=/usr/local/apache2/php
--with-config-file-path=/usr/local/apache2/php
-with-z=/usr/include/linux
i don´t know what to do with this
i am crazy with this
help me please
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=42089&edit=1